summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-21 01:35:28 +0000
committerSam James <sam@gentoo.org>2021-12-21 01:36:59 +0000
commit97929bfb6438ddaeaddf687b2d0efb5826ea23ef (patch)
treedd81564186e7532b0cfd7ccb8f543e51c52b28ad /sci-libs
parentapp-emulation/xen: drop vulnerable (diff)
downloadgentoo-97929bfb6438ddaeaddf687b2d0efb5826ea23ef.tar.gz
gentoo-97929bfb6438ddaeaddf687b2d0efb5826ea23ef.tar.bz2
gentoo-97929bfb6438ddaeaddf687b2d0efb5826ea23ef.zip
sci-libs/ginkgo: fix automagic hwloc dependency
It'll also try to download it if it can't find it on the system, so a revbump is worth it just for that as on some platforms we don't have network-sandbox (nor do we require it be used by users, even though they definitely should use it). But mainly for the automagic dep. Closes: https://bugs.gentoo.org/811384 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild (renamed from sci-libs/ginkgo/ginkgo-1.4.0-r2.ebuild)9
-rw-r--r--sci-libs/ginkgo/metadata.xml1
2 files changed, 6 insertions, 4 deletions
diff --git a/sci-libs/ginkgo/ginkgo-1.4.0-r2.ebuild b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
index 0752e5eefc9a..5092a73a706d 100644
--- a/sci-libs/ginkgo/ginkgo-1.4.0-r2.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
@@ -18,10 +18,11 @@ fi
LICENSE="BSD-with-attribution"
SLOT="0"
-IUSE="+openmp cuda"
+IUSE="cuda hwloc +openmp"
RDEPEND="
cuda? ( dev-util/nvidia-cuda-toolkit )
+ hwloc? ( sys-apps/hwloc:= )
"
DEPEND="${RDEPEND}"
@@ -42,14 +43,14 @@ src_prepare() {
}
src_configure() {
-
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF
-DGINKGO_BUILD_BENCHMARKS=OFF
-DGINKGO_BUILD_REFERENCE=ON
- -DGINKGO_BUILD_OMP=$(usex openmp)
-DGINKGO_BUILD_CUDA=$(usex cuda)
+ -DGINKGO_BUILD_HWLOC=$(usex hwloc)
+ -DGINKGO_BUILD_OMP=$(usex openmp)
)
cmake_src_configure
}
diff --git a/sci-libs/ginkgo/metadata.xml b/sci-libs/ginkgo/metadata.xml
index 604252f3caf9..56c6a1d71fc6 100644
--- a/sci-libs/ginkgo/metadata.xml
+++ b/sci-libs/ginkgo/metadata.xml
@@ -16,6 +16,7 @@
</longdescription>
<use>
<flag name="cuda">Add support for cuda assimp (<pkg>dev-util/nvidia-cuda-sdk</pkg>)</flag>
+ <flag name="hwloc">Add support for hwloc (<pkg>sys-apps/hwloc</pkg>)</flag>
</use>
<upstream>
<remote-id type="github">ginkgo-project/ginkgo</remote-id>