summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-28 18:10:05 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-28 18:10:05 -0600
commit8fcbeac51966b91f9695093e654f0c76055fa635 (patch)
tree231b138113ef59dc79a728c3c9966c1012692c32 /sys-apps/baselayout
parentnet-wireless/kismet: fix qa-sed (diff)
downloadgentoo-8fcbeac51966b91f9695093e654f0c76055fa635.tar.gz
gentoo-8fcbeac51966b91f9695093e654f0c76055fa635.tar.bz2
gentoo-8fcbeac51966b91f9695093e654f0c76055fa635.zip
sys-apps/baselayout: handle /etc/gentoo-release with CONFIG_PROTECT_MASK
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/baselayout-2.13-r1.ebuild11
1 files changed, 0 insertions, 11 deletions
diff --git a/sys-apps/baselayout/baselayout-2.13-r1.ebuild b/sys-apps/baselayout/baselayout-2.13-r1.ebuild
index afc0043d403a..64d8126ed757 100644
--- a/sys-apps/baselayout/baselayout-2.13-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-2.13-r1.ebuild
@@ -192,11 +192,6 @@ multilib_layout() {
}
pkg_preinst() {
- # This is written in src_install (so it's in CONTENTS), but punt all
- # pending updates to avoid user having to do etc-update (and make the
- # pkg_postinst logic simpler).
- rm -f "${EROOT}"/etc/._cfg????_gentoo-release || die
-
# We need to install directories and maybe some dev nodes when building
# stages, but they cannot be in CONTENTS.
# Also, we cannot reference $S as binpkg will break so we do this.
@@ -316,12 +311,6 @@ pkg_postinst() {
chmod o-rwx "${EROOT}/etc/${x}" || die
fi
done
-
- # Take care of the etc-update for the user
- if [ -e "${EROOT}"/etc/._cfg0000_gentoo-release ] ; then
- mv "${EROOT}"/etc/._cfg0000_gentoo-release "${EROOT}"/etc/gentoo-release || die
- fi
-
# whine about users that lack passwords #193541
if [[ -e "${EROOT}"/etc/shadow ]] ; then
local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${EROOT}"/etc/shadow)