summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-22 12:01:33 +0000
committerSam James <sam@gentoo.org>2023-02-22 12:31:21 +0000
commit915a015cb2b38e40a06e9d5588270e94fa11f05e (patch)
tree9310ff047c54deae8adb2d586ce0e2a79b154a27 /sys-apps/iproute2
parentdev-python/pytesseract: add python 3.11 support (diff)
downloadgentoo-915a015cb2b38e40a06e9d5588270e94fa11f05e.tar.gz
gentoo-915a015cb2b38e40a06e9d5588270e94fa11f05e.tar.bz2
gentoo-915a015cb2b38e40a06e9d5588270e94fa11f05e.zip
sys-apps/iproute2: wire up (restricted) tests
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/iproute2-6.2.0.ebuild6
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild8
2 files changed, 13 insertions, 1 deletions
diff --git a/sys-apps/iproute2/iproute2-6.2.0.ebuild b/sys-apps/iproute2/iproute2-6.2.0.ebuild
index 6c4318197517..831b5a3fbf14 100644
--- a/sys-apps/iproute2/iproute2-6.2.0.ebuild
+++ b/sys-apps/iproute2/iproute2-6.2.0.ebuild
@@ -19,6 +19,8 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
IUSE="atm berkdb bpf caps elf +iptables libbsd minimal nfs selinux split-usr"
+# Needs root
+RESTRICT="test"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
@@ -167,6 +169,10 @@ src_compile() {
emake V=1 NETNS_RUN_DIR=/run/netns
}
+src_test() {
+ emake check
+}
+
src_install() {
if use minimal ; then
into /
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index 46297152d6c6..831b5a3fbf14 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,6 +19,8 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
IUSE="atm berkdb bpf caps elf +iptables libbsd minimal nfs selinux split-usr"
+# Needs root
+RESTRICT="test"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
@@ -167,6 +169,10 @@ src_compile() {
emake V=1 NETNS_RUN_DIR=/run/netns
}
+src_test() {
+ emake check
+}
+
src_install() {
if use minimal ; then
into /