summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-12 10:00:49 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-12 10:00:49 -0400
commit808c3a6859a13ad684c3317b805f42d0fea3b131 (patch)
tree6afa1d0a5c65a6d70b8c3262b95a40b300377a50 /sys-apps/systemd
parentdev-python/google-api-core: Fix ns-related test failures (diff)
downloadgentoo-808c3a6859a13ad684c3317b805f42d0fea3b131.tar.gz
gentoo-808c3a6859a13ad684c3317b805f42d0fea3b131.tar.bz2
gentoo-808c3a6859a13ad684c3317b805f42d0fea3b131.zip
sys-apps/systemd: check for AUTOFS_FS in Linux >= 4.18
Closes: https://bugs.gentoo.org/837905 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/systemd')
-rw-r--r--sys-apps/systemd/systemd-250.4-r1.ebuild12
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
2 files changed, 18 insertions, 6 deletions
diff --git a/sys-apps/systemd/systemd-250.4-r1.ebuild b/sys-apps/systemd/systemd-250.4-r1.ebuild
index b4ec12b17bde..18d7273e17e6 100644
--- a/sys-apps/systemd/systemd-250.4-r1.ebuild
+++ b/sys-apps/systemd/systemd-250.4-r1.ebuild
@@ -181,7 +181,7 @@ pkg_pretend() {
ewarn "See https://bugs.gentoo.org/674458."
fi
- local CONFIG_CHECK="~AUTOFS4_FS ~BINFMT_MISC ~BLK_DEV_BSG ~CGROUPS
+ local CONFIG_CHECK=" ~BINFMT_MISC ~BLK_DEV_BSG ~CGROUPS
~DEVTMPFS ~EPOLL ~FANOTIFY ~FHANDLE
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX ~USER_NS
@@ -195,10 +195,16 @@ pkg_pretend() {
kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
kernel_is -ge 4 10 && CONFIG_CHECK+=" ~CGROUP_BPF"
- if kernel_is -lt 5 10 20; then
+ if kernel_is -ge 5 10 20; then
+ CONFIG_CHECK+=" ~KCMP"
+ else
CONFIG_CHECK+=" ~CHECKPOINT_RESTORE"
+ fi
+
+ if kernel_is -ge 4 18; then
+ CONFIG_CHECK+=" ~AUTOFS_FS"
else
- CONFIG_CHECK+=" ~KCMP"
+ CONFIG_CHECK+=" ~AUTOFS4_FS"
fi
if linux_config_exists; then
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 82859b1c535d..f5f763e60f72 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -181,7 +181,7 @@ pkg_pretend() {
ewarn "See https://bugs.gentoo.org/674458."
fi
- local CONFIG_CHECK="~AUTOFS4_FS ~BINFMT_MISC ~BLK_DEV_BSG ~CGROUPS
+ local CONFIG_CHECK=" ~BINFMT_MISC ~BLK_DEV_BSG ~CGROUPS
~DEVTMPFS ~EPOLL ~FANOTIFY ~FHANDLE
~INOTIFY_USER ~IPV6 ~NET ~NET_NS ~PROC_FS ~SIGNALFD ~SYSFS
~TIMERFD ~TMPFS_XATTR ~UNIX ~USER_NS
@@ -195,10 +195,16 @@ pkg_pretend() {
kernel_is -lt 4 7 && CONFIG_CHECK+=" ~DEVPTS_MULTIPLE_INSTANCES"
kernel_is -ge 4 10 && CONFIG_CHECK+=" ~CGROUP_BPF"
- if kernel_is -lt 5 10 20; then
+ if kernel_is -ge 5 10 20; then
+ CONFIG_CHECK+=" ~KCMP"
+ else
CONFIG_CHECK+=" ~CHECKPOINT_RESTORE"
+ fi
+
+ if kernel_is -ge 4 18; then
+ CONFIG_CHECK+=" ~AUTOFS_FS"
else
- CONFIG_CHECK+=" ~KCMP"
+ CONFIG_CHECK+=" ~AUTOFS4_FS"
fi
if linux_config_exists; then