summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-16 01:54:58 +0000
committerSam James <sam@gentoo.org>2022-12-16 01:54:58 +0000
commit04fe35ed3b0047c44ae7e5b32e7ab6fcedfacbd4 (patch)
tree68002ed2eadd326b91df47cf0b4ee128602e5278 /sys-apps
parentgames-simulation/flightgear: add gdal subslot dep (diff)
downloadgentoo-04fe35ed3b0047c44ae7e5b32e7ab6fcedfacbd4.tar.gz
gentoo-04fe35ed3b0047c44ae7e5b32e7ab6fcedfacbd4.tar.bz2
gentoo-04fe35ed3b0047c44ae7e5b32e7ab6fcedfacbd4.zip
sys-apps/help2man: add 1.49.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.49.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 184c445c002a..d0fcb397cf9e 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,2 +1,3 @@
DIST help2man-1.48.5.tar.xz 204672 BLAKE2B 6d96f5f65f8c637d524e5c373f2b89f114adf544c1d3508a9cb51115279b9bf6399c8ebb0a8d831de12ef8cdaca40b6e75412a221efc5d2dd1794e9c9643196f SHA512 800eb0daa9daef8e423d52ede55eee2960122ea0269865295afada4cf4fcc1c6791da8429c3a57c0fc1bf0a14c8a77953952325413a8faa5dd07b1bc5bc0edd1
DIST help2man-1.49.2.tar.xz 225428 BLAKE2B 62db47a5915432093991f060390a62ebf2d1e5e6e78f7142d0cd5f8a273a1fd74f55de4b3ead5c1071aaf4de084e62782981a1d888b8a8b76da9c07e0cda20ea SHA512 cb8f9f923263d7160a27a7924ae559aba93d7258167888eb9e0e3e97a2014297b8d739b2bb7869acbf586354d099bd91d85f8208b901bce5ba0c5ad4b6abd6d5
+DIST help2man-1.49.3.tar.xz 228472 BLAKE2B a5ed9ea3ff78b5287fa5bc02302da6a3657fee8fefd4fc43289e209bbe128d58da633c38aa4039c93a761c4842d3549a73cc14e77ee2859ed256613a8fba6e23 SHA512 5f19fad1e38b0572b63ed8bfd146b717fc22dff3a26641e8b5c8431df13da9574679d9a3407da62790db8a29286694ea1bfd751cba168f475302ad31cce845cf
diff --git a/sys-apps/help2man/help2man-1.49.3.ebuild b/sys-apps/help2man/help2man-1.49.3.ebuild
new file mode 100644
index 000000000000..c85e5630dd6d
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.49.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/ https://salsa.debian.org/bod/help2man"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+# nls/FSFAP for bindtextdomain.c
+LICENSE="GPL-3+ nls? ( FSFAP )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+# bug #385753
+DOCS=( debian/changelog NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files, bug #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}