summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-03-29 18:32:44 -0400
committerKenton Groombridge <concord@gentoo.org>2023-03-29 20:08:23 -0400
commit16a922a5558dfe748060b22fd18bd3cec8009d42 (patch)
treee5926bcc2a18800f2cca776bc8b938a1968cc9a0 /sys-apps
parentsys-apps/policycoreutils: drop 3.3 (diff)
downloadgentoo-16a922a5558dfe748060b22fd18bd3cec8009d42.tar.gz
gentoo-16a922a5558dfe748060b22fd18bd3cec8009d42.tar.bz2
gentoo-16a922a5558dfe748060b22fd18bd3cec8009d42.zip
sys-apps/selinux-python: drop 3.3
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/selinux-python/Manifest1
-rw-r--r--sys-apps/selinux-python/selinux-python-3.3.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/sys-apps/selinux-python/Manifest b/sys-apps/selinux-python/Manifest
index 12857bc0cf7c..d30b9ce02a65 100644
--- a/sys-apps/selinux-python/Manifest
+++ b/sys-apps/selinux-python/Manifest
@@ -1,3 +1,2 @@
-DIST selinux-python-3.3.tar.gz 2101584 BLAKE2B 603aafbf316b744098bd34c79bf384d55624c086fd75147675a4a0715df3d61710a99d490f30b78d59a2c2a85fcc4db91772c24644a963b31e1a0d305c4bc83e SHA512 a69948a8b139a309f18632440e4204f49832a94b8b6be50e162d3dacb16698effeb1a77c44462e8cc7dc3dd600b887b9ab2fef618c31d3e0fe0de216a6aaebe3
DIST selinux-python-3.4.tar.gz 3596450 BLAKE2B b98f6ba63814a4281c5ea624b2b0f68c6ae92e4447dd6078a0d70bce34534b0a457f0a9533e1db1fbf665b8a0b379adf78fd8ba8f3ae19973b74a3332157842b SHA512 d601ce2628c4876dc4f2dfccd6db8ff45f68c5eb1b14cec3328644b71959107546469b27dfd90488fc669019b341d0cba708a1797f427ac7f86a0f05e86c0948
DIST selinux-python-3.5.tar.gz 3604439 BLAKE2B 5a7fcd303c337cb0f5ae0066d13c945bb5cacaba472c7b17f0496295294998fcc6d81c153720ef704b749a01590c28b48b4f471a48fc386b8f02564c3550250b SHA512 2ac176a9f078f2b2721e5871ba21e92041eed54fc692fd8d809ff14327beee6de63b3084d0f1053a640b9e40bcc6461498915bb9b038a658cd772f77d80fd217
diff --git a/sys-apps/selinux-python/selinux-python-3.3.ebuild b/sys-apps/selinux-python/selinux-python-3.3.ebuild
deleted file mode 100644
index 6984565f532b..000000000000
--- a/sys-apps/selinux-python/selinux-python-3.3.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_9 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit python-r1 toolchain-funcs
-
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="SELinux core utilities"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${P}/${PN#selinux-}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~mips x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND=">=sys-libs/libselinux-${PV}:=[python]
- >=sys-libs/libsemanage-${PV}:=[python(+)]
- >=sys-libs/libsepol-${PV}:=
- >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? (
- ${RDEPEND}
- >=sys-apps/secilc-${PV}
- )"
-
-src_prepare() {
- default
- sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
-
- python_copy_sources
-}
-
-src_compile() {
- building() {
- emake -C "${BUILD_DIR}" \
- CC="$(tc-getCC)" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
- }
- python_foreach_impl building
-}
-
-src_test() {
- testing() {
- # The different subprojects have some interproject dependencies:
- # - audit2allow depens on sepolgen
- # - chcat depends on semanage
- # and maybe others.
- # Add all the modules of the individual subprojects to the
- # PYTHONPATH, so they get actually found and used. In
- # particular, already installed versions on the system are not
- # used.
- for dir in audit2allow chcat semanage sepolgen/src sepolicy ; do
- PYTHONPATH="${BUILD_DIR}/${dir}:${PYTHONPATH}"
- done
- PYTHONPATH=${PYTHONPATH} \
- emake -C "${BUILD_DIR}" \
- test
- }
- python_foreach_impl testing
-}
-
-src_install() {
- installation() {
- emake -C "${BUILD_DIR}" \
- DESTDIR="${D}" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- install
- python_optimize
- }
- python_foreach_impl installation
-
- # Set version-specific scripts
- for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
- python_replicate_script "${ED}/usr/bin/${pyscript}"
- done
- for pyscript in semanage; do
- python_replicate_script "${ED}/usr/sbin/${pyscript}"
- done
-
- # Create sepolgen.conf with different devel location definition
- if [[ -f /etc/selinux/config ]];
- then
- local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config);
- mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory";
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- local selinuxtype="${POLICY_TYPES%% *}";
- if [[ -n "${selinuxtype}" ]];
- then
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf;
- else
- echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf;
- fi
- fi
-}