summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2023-03-29 18:19:52 -0400
committerKenton Groombridge <concord@gentoo.org>2023-03-29 20:07:57 -0400
commit80fabc3fc0f2c16702b06dd3469d2a2d2f170c6f (patch)
tree392055d4d7c9c311e5c4c785a9b35aa8ec1e7f16 /sys-apps
parentsys-libs/libsepol: bump to 3.5 (diff)
downloadgentoo-80fabc3fc0f2c16702b06dd3469d2a2d2f170c6f.tar.gz
gentoo-80fabc3fc0f2c16702b06dd3469d2a2d2f170c6f.tar.bz2
gentoo-80fabc3fc0f2c16702b06dd3469d2a2d2f170c6f.zip
sys-apps/secilc: bump to 3.5
Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-3.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index 2763c2fd0840..07ef13a7f3c6 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1,2 +1,3 @@
DIST secilc-3.3.tar.gz 181205 BLAKE2B ffccf2e6ea416f6e5a8270a488c6c6ed01b607af20fffed129f5d9b9957f2ab16e90a3fdbd57b597f1195987edf6a2ca1ae561cca62d176a01878fe24900f4b9 SHA512 11b2b6a56d588a71d8cc5b2e69e76579ddd3ea20e036bbfdbeefd8ed64a6dca3c8f963509a96231eb21807a195ec24e4807ef52dc2218ee0410ee0828ad77fa8
DIST secilc-3.4.tar.gz 181312 BLAKE2B cee26f3b6dc3d7a48df3bd3c9e0edf15f92f55b399afe02d7f4efe10cfd1d8ec140aa5ed588003c6ffca95e1abc82a6163f86edc58ea140703f47ca4bf2d5179 SHA512 f29ff42dd60050cdd4367af38b334876817f8e33ed40a9be89304beea840a210bd9a58d658d0b09f98bad54b12b185a0262ca05094b63e7f96c0142729699c3b
+DIST secilc-3.5.tar.gz 180803 BLAKE2B a42620318b312a5ef35565e3b40a89fd7ff44aaf73de835bc349f927193121b72c07bd2151a8a6b2cee53e2699a3ae6bb246084e18a181d334ebc082fdfdc56e SHA512 eff37a981072c4b9c7c15bf4709db8797d8af5325883515f5c2fe611136b24419f6d01c797e4f131c9c08e1ba40576fcb2094b1e34325aae8351b6299bdba3dd
diff --git a/sys-apps/secilc/secilc-3.5.ebuild b/sys-apps/secilc/secilc-3.5.ebuild
new file mode 100644
index 000000000000..76eeb7422445
--- /dev/null
+++ b/sys-apps/secilc/secilc-3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit toolchain-funcs
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}"
+RDEPEND="${DEPEND}"
+BDEPEND="app-text/xmlto"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_compile() {
+ tc-export CC
+ default
+}