summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-16 08:42:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-16 08:43:00 +0100
commitc53a6004192d8b595c7a7ad0b24e23ac2b922249 (patch)
tree3a321ed8c38b9427dc8367a3f08ad85788da37fd /sys-libs/newlib
parentsys-libs/newlib: restore newlib-3.1.0 for msp430 (diff)
downloadgentoo-c53a6004192d8b595c7a7ad0b24e23ac2b922249.tar.gz
gentoo-c53a6004192d8b595c7a7ad0b24e23ac2b922249.tar.bz2
gentoo-c53a6004192d8b595c7a7ad0b24e23ac2b922249.zip
sys-libs/newlib: add early error for msp430
Reported-by: tomtom69 Bug: https://bugs.gentoo.org/717610 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/newlib-3.3.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-libs/newlib/newlib-3.3.0.ebuild b/sys-libs/newlib/newlib-3.3.0.ebuild
index db1a3fad9cfb..95217157d87a 100644
--- a/sys-libs/newlib/newlib-3.3.0.ebuild
+++ b/sys-libs/newlib/newlib-3.3.0.ebuild
@@ -48,6 +48,13 @@ pkg_setup() {
*) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
esac
fi
+
+ case ${CTARGET} in
+ msp430*)
+ # bug #717610
+ die "gcc on ${CTARGET} needs older newlib. Use newlib-3.1.0."
+ ;;
+ esac
}
src_configure() {