summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-02 14:53:18 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-02 14:53:29 +0100
commit17a67de2070b1d1d40ba1f66165c6890867d9a2e (patch)
tree18a2ac338ad7a8036508fbc853334f16eabb9956 /www-client
parentwww-client/uget: add 2.2.3 (diff)
downloadgentoo-17a67de2070b1d1d40ba1f66165c6890867d9a2e.tar.gz
gentoo-17a67de2070b1d1d40ba1f66165c6890867d9a2e.tar.bz2
gentoo-17a67de2070b1d1d40ba1f66165c6890867d9a2e.zip
www-client/uget: Sync with latest changes
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/uget/uget-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/www-client/uget/uget-9999.ebuild b/www-client/uget/uget-9999.ebuild
index 107388398e44..bd1d745b7b0e 100644
--- a/www-client/uget/uget-9999.ebuild
+++ b/www-client/uget/uget-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3 xdg
DESCRIPTION="Download manager using gtk+ and libcurl"
HOMEPAGE="http://www.ugetdm.com"
-EGIT_REPO_URI="git://git.code.sf.net/p/urlget/uget2"
+EGIT_REPO_URI="https://git.code.sf.net/p/urlget/uget2"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -24,16 +24,22 @@ RDEPEND="
dev-libs/libgcrypt:0
)
aria2? ( net-misc/aria2[xmlrpc] )
- appindicator? ( dev-libs/libappindicator:3 )
+ appindicator? ( dev-libs/libayatana-appindicator )
gstreamer? ( media-libs/gstreamer:1.0 )
openssl? ( dev-libs/openssl:= )
- libnotify? ( x11-libs/libnotify )"
+ libnotify? ( x11-libs/libnotify )
+"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
virtual/pkgconfig
sys-devel/gettext"
+PATCHES=(
+ # https://github.com/ugetdm/uget/issues/49
+ "${FILESDIR}"/${PN}-2.2.1-ayatana.patch
+)
+
src_prepare() {
default
eautoreconf