summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-04-17 22:48:55 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-04-17 22:49:33 +0300
commit6811f5ee3149ba0317b3d64c345c57d79447d190 (patch)
tree1612d95399c4b101eb23a88fde503841d0cabbee /www-client
parentnet-print/cups-filters: remove unused file (diff)
downloadgentoo-6811f5ee3149ba0317b3d64c345c57d79447d190.tar.gz
gentoo-6811f5ee3149ba0317b3d64c345c57d79447d190.tar.bz2
gentoo-6811f5ee3149ba0317b3d64c345c57d79447d190.zip
www-client/pybugz: works with py3.10
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/pybugz/pybugz-0.13-r2.ebuild34
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild4
2 files changed, 36 insertions, 2 deletions
diff --git a/www-client/pybugz/pybugz-0.13-r2.ebuild b/www-client/pybugz/pybugz-0.13-r2.ebuild
new file mode 100644
index 000000000000..2b5d117d6319
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.13-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="readline(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+}
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
index f95c65ea1b0d..45e9b2e4c247 100644
--- a/www-client/pybugz/pybugz-9999.ebuild
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="readline(+)"
if [ "${PV}" = "9999" ]; then