summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 17:42:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 17:45:13 +0100
commit050a351139feea0f6ac6071c467e3344032011dc (patch)
treeb0d9cf122a9f1378904c11feb811916d7f901fa0 /xfce-extra
parentdev-libs/newt: add 0.52.24 (diff)
downloadgentoo-050a351139feea0f6ac6071c467e3344032011dc.tar.gz
gentoo-050a351139feea0f6ac6071c467e3344032011dc.tar.bz2
gentoo-050a351139feea0f6ac6071c467e3344032011dc.zip
xfce-extra/thunar-archive-plugin: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index ecfc93ea3a00..9aa8154455a1 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-archive-plugin-0.5.1.tar.bz2 369808 BLAKE2B 4a548f2249c5fe84e797759a6d6ac28f3ad0dbdc1361950e2593be55541500e5937b34d0408b3c66a1b964d58b2c2fe4c012a323d46defb4b3f56ec1442d229e SHA512 e79c60d42a3c40007b361fca918977a84c6f8737136f06b0ef073ce574731162fc2145d2563d751b3cf73222e38361aa1ef6435eec90fce7d86d43102e674051
+DIST thunar-archive-plugin-0.5.2.tar.bz2 371599 BLAKE2B a32e0d7c42ad075d2f40d815ca74b86bb0a9a3a2db8c4e2146d3e90b12d7ba4e72b7f75703adcc6aeca702b1124cbe833e80def9891498056c8e0c0483318cab SHA512 f334b960c623bc6c5736ba38d0e965b4e8d4f22fe857a66301c36c255701a702f839d6f63f67b37bc665066d75d787ea8159d4eed7561a2ecd98340bdcb65bc0
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.2.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.2.ebuild
new file mode 100644
index 000000000000..474e6fb27bd4
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/thunar/archive
+ https://gitlab.xfce.org/thunar-plugins/thunar-archive-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}