summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config/webapp-config-9999.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 80bc77e30465..9aad95348cfe 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 prefix
@@ -38,6 +38,11 @@ python_compile_all() {
emake -C doc/
}
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
python_install() {
# According to this discussion:
# http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
@@ -60,11 +65,6 @@ python_install_all() {
doman doc/*.[58]
}
-python_test() {
- PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
- die "Testing failed with ${EPYTHON}"
-}
-
pkg_postinst() {
elog "Now that you have upgraded webapp-config, you **must** update your"
elog "config files in /etc/vhosts/webapp-config before you emerge any"