summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libprelude/libprelude-4.0.0.ebuild9
-rw-r--r--dev-libs/libprelude/libprelude-4.1.0.ebuild9
-rw-r--r--dev-libs/libprelude/libprelude-5.1.1.ebuild9
3 files changed, 9 insertions, 18 deletions
diff --git a/dev-libs/libprelude/libprelude-4.0.0.ebuild b/dev-libs/libprelude/libprelude-4.0.0.ebuild
index fd2139e4e0fe..f8d9794f1d45 100644
--- a/dev-libs/libprelude/libprelude-4.0.0.ebuild
+++ b/dev-libs/libprelude/libprelude-4.0.0.ebuild
@@ -54,6 +54,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with lua)
$(use_with perl)
$(usex perl '--with-perl-installdirs=vendor' '')
@@ -62,13 +63,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/libprelude/libprelude-4.1.0.ebuild b/dev-libs/libprelude/libprelude-4.1.0.ebuild
index 4bc3cf9bdb99..4c32375c5be5 100644
--- a/dev-libs/libprelude/libprelude-4.1.0.ebuild
+++ b/dev-libs/libprelude/libprelude-4.1.0.ebuild
@@ -54,6 +54,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with lua)
$(use_with perl)
$(usex perl '--with-perl-installdirs=vendor' '')
@@ -62,13 +63,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/libprelude/libprelude-5.1.1.ebuild b/dev-libs/libprelude/libprelude-5.1.1.ebuild
index 72e4580f9527..dbcd337b3b76 100644
--- a/dev-libs/libprelude/libprelude-5.1.1.ebuild
+++ b/dev-libs/libprelude/libprelude-5.1.1.ebuild
@@ -63,6 +63,7 @@ src_configure() {
local myconf=(
--enable-easy-bindings
--with-swig
+ --without-python2
$(use_with lua)
$(use_with perl)
$(usex perl '--with-perl-installdirs=vendor' '')
@@ -71,13 +72,9 @@ src_configure() {
if use python; then
python_setup
- if python_is_python3; then
- myconf+=(--without-python2 --with-python3="${EPYTHON}")
- else
- myconf+=(--without-python3 --with-python2="${EPYTHON}")
- fi
+ myconf+=( --with-python3="${EPYTHON}" )
else
- myconf+=(--without-python2 --without-python3)
+ myconf+=( --without-python3 )
fi
econf "${myconf[@]}"