summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-4.3.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 11c645649e89..c3ae43aa0954 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1,2 +1,3 @@
DIST pikepdf-4.2.0.tar.gz 2337822 BLAKE2B ca966ae2c1be1805cc6ce99e34eb6692fe89bf29f1e6a3161eb04daa52e3890ae8d8859e4165801395efc5d3364d215ea5fc659fb344388a36bf32b638ad72bf SHA512 a01e2b0defbf6689b7d47346a85c07ae575ae57833d5be93e4099890ed5bb5b205595dc43ddd917ab4adc87ad591199c728c886358b8d4c03b1522193428e23d
DIST pikepdf-4.3.0.tar.gz 2348313 BLAKE2B 8e3a98fae1406a1c704d0c2341eebf142ab5d774f861e85ee83605ea56a433d96b85ec501171d4c8f9b2e905b7d06b8075191efea7e58e80f86abf046c2c698d SHA512 c23866e2e9cc36916823d6740f63900d0d1bf3fa7fb226c7f3ae2e0f1bda2808f2ac469ec38a3c147cf124d7473d63cd13ee34a09d9bf74cef29b76589c93ff4
+DIST pikepdf-4.3.1.tar.gz 2348339 BLAKE2B 9b1f04a87e7e7d2dc2589eaa7db4a670e8ceda753191e473e1a5da9ead532121d0d7d4f734fa234d60a9b5a5931d022f46e252a8c69947e9553df67b81043a06 SHA512 0156ad57a9af2d39538f9f728231e931e1a44ecea74d26e850640fa062f2dc60d427deeea5fc25ab33037d11d7a403cefe5f930c7ed92be92a6d3432f87d8fa6
diff --git a/dev-python/pikepdf/pikepdf-4.3.1.ebuild b/dev-python/pikepdf/pikepdf-4.3.1.ebuild
new file mode 100644
index 000000000000..f4a8e05a4b77
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-4.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV/_p/.post}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=app-text/qpdf-10.3.1:0="
+RDEPEND="${DEPEND}
+ >=dev-python/pillow-7[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pybind11-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )"
+
+#distutils_enable_sphinx docs \
+# dev-python/ipython \
+# dev-python/matplotlib \
+# dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/-n auto/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}