summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-5.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index d2e6ef73a019..bbd06ae4e24f 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1 +1,2 @@
DIST tekore-4.6.1.gh.tar.gz 264775 BLAKE2B 38371bfd377c51d0dc790ad1571573709b6f233e1174addb1621ae7603a50a3dfd7274d74243f95c51b94ab22143e69417ad02110a71d5db4d98516f29b9a308 SHA512 0e76434da0a03e2e808009ca471bcf2dae25db0cc27769d5df9ec1075ca177d3d6faaa35fbf3532646b6bad27dc503c8262361dda23127ee3b8bc4e4e4abfe06
+DIST tekore-5.0.0.gh.tar.gz 261056 BLAKE2B 3d3659d68329b0cd4de655cae018b89ad0bbe0173087f11b3ad9cf6af0be60a6c0202978316321c4962ff6259126159b84d48a8dafe916f687a8098240d218dd SHA512 60e269bac72b7717f7f81a2865b4e317c7d4f161457b8c12073150dbc3a1ea8307c3256e28381cc4c7b1f1daf698c9083890f498d0d96067d4bd1df5f15b10da
diff --git a/dev-python/tekore/tekore-5.0.0.ebuild b/dev-python/tekore/tekore-5.0.0.ebuild
new file mode 100644
index 000000000000..b3065a6e048c
--- /dev/null
+++ b/dev-python/tekore/tekore-5.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.25[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)