summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-78.10.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/mail-client/thunderbird/thunderbird-78.10.1.ebuild b/mail-client/thunderbird/thunderbird-78.10.1.ebuild
index b2bba3955d0a..44fab69764a2 100644
--- a/mail-client/thunderbird/thunderbird-78.10.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-78.10.1.ebuild
@@ -192,6 +192,11 @@ DEPEND="${CDEPEND}
S="${WORKDIR}/${PN}-${PV%_*}"
llvm_check_deps() {
+ if ! has_version -b "sys-devel/llvm:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/llvm:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1