summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamdyke/metadata.xml2
-rw-r--r--mail-filter/spamdyke/spamdyke-4.3.0-r1.ebuild9
-rw-r--r--mail-filter/spamdyke/spamdyke-4.3.0.ebuild13
3 files changed, 13 insertions, 11 deletions
diff --git a/mail-filter/spamdyke/metadata.xml b/mail-filter/spamdyke/metadata.xml
index 151d9449c37c..e8a572fa95e4 100644
--- a/mail-filter/spamdyke/metadata.xml
+++ b/mail-filter/spamdyke/metadata.xml
@@ -13,6 +13,6 @@ features to enhance qmail.
Best of all, using spamdyke does not require patching or recompiling qmail!
</longdescription>
<use>
- <flag name='tls'>Enables TLS protocol for spamdyke</flag>
+ <flag name='ssl'>Enables TLS protocol for spamdyke</flag>
</use>
</pkgmetadata>
diff --git a/mail-filter/spamdyke/spamdyke-4.3.0-r1.ebuild b/mail-filter/spamdyke/spamdyke-4.3.0-r1.ebuild
index 28f444895cb2..a37bc83aa85f 100644
--- a/mail-filter/spamdyke/spamdyke-4.3.0-r1.ebuild
+++ b/mail-filter/spamdyke/spamdyke-4.3.0-r1.ebuild
@@ -3,6 +3,7 @@
# $Id$
EAPI="5"
+
inherit eutils autotools
DESCRIPTION="A drop-in connection-time spam filter for qmail"
@@ -12,10 +13,10 @@ SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="libressl +tls"
+IUSE="libressl +ssl"
DEPEND="
- tls? (
+ ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)"
@@ -27,7 +28,7 @@ S=${WORKDIR}/${P}/${PN}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc46.patch
echo "# Configuration option for ${PN}" > ${PN}.conf
- if use tls; then
+ if use ssl; then
echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
>> ${PN}.conf
fi
@@ -45,7 +46,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable tls) || die "econf failed"
+ $(use_enable ssl tls) || die "econf failed"
cd ../utils
econf || die "econf failed in utils"
}
diff --git a/mail-filter/spamdyke/spamdyke-4.3.0.ebuild b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
index e3491cace8b0..18dbbc7848c4 100644
--- a/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
+++ b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI="5"
+
inherit eutils autotools
DESCRIPTION="A drop-in connection-time spam filter for qmail"
@@ -12,9 +13,9 @@ SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+tls"
+IUSE="+ssl"
-DEPEND="tls? ( dev-libs/openssl )"
+DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
virtual/qmail"
@@ -23,7 +24,7 @@ S=${WORKDIR}/${P}/${PN}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc46.patch
echo "# Configuration option for ${PN}" > ${PN}.conf
- if use tls; then
+ if use ssl; then
echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
>> ${PN}.conf
fi
@@ -41,7 +42,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable tls) || die "econf failed"
+ $(use_enable ssl tls) || die "econf failed"
cd ../utils
econf || die "econf failed in utils"
}