summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/lldpd')
-rw-r--r--net-misc/lldpd/files/lldpd-1.0.3-fix-fdp-without-cdp.patch30
-rw-r--r--net-misc/lldpd/lldpd-1.0.3.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/lldpd/files/lldpd-1.0.3-fix-fdp-without-cdp.patch b/net-misc/lldpd/files/lldpd-1.0.3-fix-fdp-without-cdp.patch
new file mode 100644
index 000000000000..17099a2f819b
--- /dev/null
+++ b/net-misc/lldpd/files/lldpd-1.0.3-fix-fdp-without-cdp.patch
@@ -0,0 +1,30 @@
+commit 4e7ec8233cd185941eaa9e41785cfc53f92799b4
+Author: Vincent Bernat <vincent@bernat.ch>
+Date: Tue Jan 8 17:19:15 2019 -0500
+
+ build: fix compilation with `--enable-fdp --disable-cdp`
+
+ Fix #315
+
+diff --git a/src/lldpd-structs.h b/src/lldpd-structs.h
+index c3ffa10..f6b03d7 100644
+--- a/src/lldpd-structs.h
++++ b/src/lldpd-structs.h
+@@ -129,7 +129,7 @@ struct lldpd_dot3_power {
+ MARSHAL(lldpd_dot3_power);
+ #endif
+
+-#ifdef ENABLE_CDP
++#if defined (ENABLE_CDP) || defined (ENABLE_FDP)
+ struct cdpv2_power {
+ u_int16_t request_id;
+ u_int16_t management_id;
+@@ -273,7 +273,7 @@ struct lldpd_port {
+ struct lldpd_med_power p_med_power;
+ #endif
+
+-#ifdef ENABLE_CDP
++#if defined (ENABLE_CDP) || defined (ENABLE_FDP)
+ struct cdpv2_power p_cdp_power;
+ #endif
+
diff --git a/net-misc/lldpd/lldpd-1.0.3.ebuild b/net-misc/lldpd/lldpd-1.0.3.ebuild
index 226f947f3bdf..822e037de615 100644
--- a/net-misc/lldpd/lldpd-1.0.3.ebuild
+++ b/net-misc/lldpd/lldpd-1.0.3.ebuild
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}/lldpd-0.9.5-seccomp-add-socket-ops.patch"
"${FILESDIR}/lldpd-1.0.1-seccomp-add-brk.patch"
"${FILESDIR}/lldpd-1.0.2-seccomp-add-misc.patch"
+ "${FILESDIR}/lldpd-1.0.3-fix-fdp-without-cdp.patch"
)
pkg_setup() {