summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/molden')
-rw-r--r--sci-chemistry/molden/molden-5.5.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-chemistry/molden/molden-5.5.ebuild b/sci-chemistry/molden/molden-5.5.ebuild
index 425238389f6e..2587fffdd9be 100644
--- a/sci-chemistry/molden/molden-5.5.ebuild
+++ b/sci-chemistry/molden/molden-5.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit desktop fortran-2 flag-o-matic toolchain-funcs
MY_P="${PN}${PV}"
@@ -51,6 +52,10 @@ src_compile() {
# Use -mieee on alpha, according to the Makefile
use alpha && append-flags -mieee
+ # GCC 10 workaround
+ # bug #724556
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
args=(
CC="$(tc-getCC) ${CFLAGS}"
FC="$(tc-getFC)"