summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:48:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-10 19:48:57 +0000
commita0c625d44144d20ec2cfab6615abad4fbff0fc0e (patch)
treedc1f137c0678667886c1808889ddc9c53103182f
parentRespect LDFLAGS. (diff)
downloadhistorical-a0c625d44144d20ec2cfab6615abad4fbff0fc0e.tar.gz
historical-a0c625d44144d20ec2cfab6615abad4fbff0fc0e.tar.bz2
historical-a0c625d44144d20ec2cfab6615abad4fbff0fc0e.zip
Update EAPI. Fix dependencies. Don't inherit distutils.eclass and python.eclass twice. Use PyPI mirrors. Set PYTHON_MODNAME. Set TWISTED_PLUGINS and avoid custom regeneration of Twisted plugin cache.
Package-Manager: portage-2.2_rc91_p7/cvs/Linux x86_64
-rw-r--r--dev-python/mantissa/ChangeLog10
-rw-r--r--dev-python/mantissa/mantissa-0.7.0.ebuild43
-rw-r--r--dev-python/nevow/Manifest4
3 files changed, 18 insertions, 39 deletions
diff --git a/dev-python/mantissa/ChangeLog b/dev-python/mantissa/ChangeLog
index 6c7f5ee0025b..f3891a0d3462 100644
--- a/dev-python/mantissa/ChangeLog
+++ b/dev-python/mantissa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mantissa
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.14 2009/11/30 14:27:22 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/ChangeLog,v 1.15 2010/10/10 19:48:57 arfrever Exp $
+
+ 10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mantissa-0.7.0.ebuild:
+ Update EAPI. Fix dependencies. Don't inherit distutils.eclass and
+ python.eclass twice. Use PyPI mirrors. Set PYTHON_MODNAME. Set
+ TWISTED_PLUGINS and avoid custom regeneration of Twisted plugin cache.
*mantissa-0.7.0 (30 Nov 2009)
diff --git a/dev-python/mantissa/mantissa-0.7.0.ebuild b/dev-python/mantissa/mantissa-0.7.0.ebuild
index cb82a6fd3b64..5f857e841dba 100644
--- a/dev-python/mantissa/mantissa-0.7.0.ebuild
+++ b/dev-python/mantissa/mantissa-0.7.0.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.7.0.ebuild,v 1.4 2010/03/07 10:20:27 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mantissa/mantissa-0.7.0.ebuild,v 1.5 2010/10/10 19:48:57 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
DISTUTILS_SRC_TEST="trial xmantissa"
DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
# setup.py uses epsilon.setuphelper.autosetup(), which tries to use
# build-${PYTHON_ABI} directories as packages.
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-inherit distutils twisted
+inherit twisted
MY_PN="Mantissa"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
HOMEPAGE="http://divmod.org/trac/wiki/DivmodMantissa http://pypi.python.org/pypi/Mantissa"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -34,12 +36,12 @@ DEPEND=">=dev-python/axiom-0.5.7
dev-python/twisted-mail
>=dev-python/vertex-0.2.0"
RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
DOCS="NAME.txt NEWS.txt"
-PYTHON_MODNAME="axiom nevow xmantissa"
+PYTHON_MODNAME="axiom/plugins nevow/plugins/mantissa_package.py xmantissa"
+TWISTED_PLUGINS="axiom.plugins nevow.plugins xmantissa.plugins"
src_compile() {
# Skip distutils_src_compile to avoid installation of $(python_get_sitedir)/build directory.
@@ -53,32 +55,3 @@ src_test() {
src_install() {
PORTAGE_PLUGINCACHE_NOOP="1" distutils_src_install
}
-
-update_axiom_plugin_cache() {
- einfo "Updating axiom plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from axiom import plugins; list(getPlugins(IPlugin, plugins))'
-}
-
-update_mantissa_plugin_cache() {
- einfo "Updating mantissa plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from xmantissa import plugins; list(getPlugins(IPlugin, plugins))'
-}
-
-update_nevow_plugin_cache() {
- einfo "Updating nevow plugin cache..."
- "$(PYTHON)" -c 'from twisted.plugin import IPlugin, getPlugins;from nevow import plugins; list(getPlugins(IPlugin, plugins))'
-}
-
-pkg_postinst() {
- twisted_pkg_postinst
- python_execute_function update_axiom_plugin_cache
- python_execute_function update_nevow_plugin_cache
- python_execute_function update_mantissa_plugin_cache
-}
-
-pkg_postrm() {
- twisted_pkg_postrm
- python_execute_function update_axiom_plugin_cache
- python_execute_function update_nevow_plugin_cache
- python_execute_function update_mantissa_plugin_cache
-}
diff --git a/dev-python/nevow/Manifest b/dev-python/nevow/Manifest
index 8941d64e2252..8697a19a49c8 100644
--- a/dev-python/nevow/Manifest
+++ b/dev-python/nevow/Manifest
@@ -1,4 +1,4 @@
DIST Nevow-0.10.0.tar.gz 518696 RMD160 301fbe3fdd275618c5ea5c7fec2bb95cca4007a7 SHA1 134c795581df70649d0c11d8619b8b4e7d3749e6 SHA256 90631f68f626c8934984908d3df15e7c198939d36be7ead1305479dfc67ff6d0
-EBUILD nevow-0.10.0.ebuild 1637 RMD160 9531c157154de3794aab98b67552be520a7e353c SHA1 405efc5a8944d38d059823c21783c4a1170d2cca SHA256 bd80048a3a9077b6229ef432e82710f57c26e0c1ada6fc6c437dd446ba423411
-MISC ChangeLog 5775 RMD160 ff8cd852820ce30e5f16eac06a5af1877c602985 SHA1 87c44d96d72d56321baa3af2ea18ebde39bd843a SHA256 82162c7b70c4a8fe0203cd26bc00480739d65988fd4e9522ed3ba28975ecfff5
+EBUILD nevow-0.10.0.ebuild 1244 RMD160 dbcdc73e16183181cc50ea4b101c69355b21feca SHA1 204dd57e7520a8bac38f07a13c4d94b9b9a394a9 SHA256 34fbbb9c13e7eb9af7d71fadc50e1686e09a1b0364e66ab40346742736bcbdc6
+MISC ChangeLog 6039 RMD160 57d7a2a55b2b938bf703e05aac5754d96c30c310 SHA1 566205d1c9e2b5f1cc7b5172ee13ec0328c1d4da SHA256 3ca9e2103fb063c888853a87d856196de750157a1fb47c5f1139d9295b97f1ea
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a