summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-12-28 10:16:12 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-12-28 10:16:12 +0000
commitde9ed3b20232483b1a9432eef2793b0d3def0376 (patch)
tree23b42478c758c91641516b382b36e581dfe17074
parentAdded app-laptop/tp_smapi:hdaps (diff)
downloadhistorical-de9ed3b20232483b1a9432eef2793b0d3def0376.tar.gz
historical-de9ed3b20232483b1a9432eef2793b0d3def0376.tar.bz2
historical-de9ed3b20232483b1a9432eef2793b0d3def0376.zip
Version bump.
Package-Manager: portage-2.0.53
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/Manifest12
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.131
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.13.ebuild42
4 files changed, 56 insertions, 6 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 589c6f01e112..06b2f32ada69 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.3 2005/12/17 15:22:57 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.4 2005/12/28 10:16:12 brix Exp $
+
+*tp_smapi-0.13 (28 Dec 2005)
+
+ 28 Dec 2005; Henrik Brix Andersen <brix@gentoo.org> +tp_smapi-0.13.ebuild:
+ Version bump.
*tp_smapi-0.12 (17 Dec 2005)
diff --git a/app-laptop/tp_smapi/Manifest b/app-laptop/tp_smapi/Manifest
index aa8a278a1559..bfb200c7808c 100644
--- a/app-laptop/tp_smapi/Manifest
+++ b/app-laptop/tp_smapi/Manifest
@@ -1,8 +1,10 @@
-MD5 666f60fc9240a3097a5c69f242dfab90 tp_smapi-0.09.ebuild 758
-MD5 a321749b92e57b4bc3059af495bae535 tp_smapi-0.10.ebuild 758
-MD5 d1a33ec0e5954c109ccc19f52d654cd5 tp_smapi-0.12.ebuild 758
-MD5 195b45204190b58f7268c89ee9c2d97c ChangeLog 613
-MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
+MD5 aa10e024e7962f8990e8129df1f48354 ChangeLog 737
MD5 4d7f53e3ed49793eab511c3f2b3bddb4 files/digest-tp_smapi-0.09 61
MD5 f18aaa92ad22a269103dbf2c2e1b456b files/digest-tp_smapi-0.10 61
MD5 fa7a6dd24bc902e937c5ff2d8a0d0e6d files/digest-tp_smapi-0.12 61
+MD5 998c3b5bb9e1c64b69b5778cd369fac4 files/digest-tp_smapi-0.13 61
+MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
+MD5 666f60fc9240a3097a5c69f242dfab90 tp_smapi-0.09.ebuild 758
+MD5 a321749b92e57b4bc3059af495bae535 tp_smapi-0.10.ebuild 758
+MD5 d1a33ec0e5954c109ccc19f52d654cd5 tp_smapi-0.12.ebuild 758
+MD5 3794ac7eea9a858ee4ceb7e09334cd12 tp_smapi-0.13.ebuild 893
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.13 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.13
new file mode 100644
index 000000000000..996109ed818b
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.13
@@ -0,0 +1 @@
+MD5 5d9fee1bc7ecc8e683a22612337bc3b7 tp_smapi-0.13.tgz 18244
diff --git a/app-laptop/tp_smapi/tp_smapi-0.13.ebuild b/app-laptop/tp_smapi/tp_smapi-0.13.ebuild
new file mode 100644
index 000000000000..1cb3222bf860
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.13.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.13.ebuild,v 1.1 2005/12/28 10:16:12 brix Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="hdaps"
+
+BUILD_TARGETS="default"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 13; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.13 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="tp_base(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}