summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2012-03-05 16:20:01 +0000
committerJim Ramsay <lack@gentoo.org>2012-03-05 16:20:01 +0000
commitd370e551283a130f83ab97b62ba579b11ccc3618 (patch)
tree26348ab130b07c4360e0833229b009574819020d /app-editors/vim
parentfixed numlock issue, bug #405579 -- thanks to Vincent for the patch. (diff)
downloadhistorical-d370e551283a130f83ab97b62ba579b11ccc3618.tar.gz
historical-d370e551283a130f83ab97b62ba579b11ccc3618.tar.bz2
historical-d370e551283a130f83ab97b62ba579b11ccc3618.zip
Version bump: 7.3.462 is released
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/vim-7.3.462.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index 97e1b9e87e05..beb1b5b154dc 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.404 2012/03/05 10:19:48 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.405 2012/03/05 16:19:29 lack Exp $
+
+*vim-7.3.462 (05 Mar 2012)
+
+ 05 Mar 2012; Jim Ramsay <jim_ramsay@gentoo.org> +vim-7.3.462.ebuild:
+ Version bump: 7.3.462 is released
05 Mar 2012; Jeff Horelick <jdhore@gentoo.org> vim-7.3.409.ebuild:
marked x86 per bug 406427
diff --git a/app-editors/vim/vim-7.3.462.ebuild b/app-editors/vim/vim-7.3.462.ebuild
new file mode 100644
index 000000000000..2157f5917732
--- /dev/null
+++ b/app-editors/vim/vim-7.3.462.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.3.462.ebuild,v 1.1 2012/03/05 16:19:29 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.patch.bz2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ http://dev.gentoo.org/~lack/vim/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.3-interix-link.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+}