summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-08-20 14:54:00 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-08-20 14:54:00 +0000
commit2c967bc19e39dbe97ddaaed2ebb3b161146836d3 (patch)
treeb75b5ff6e5db181a60d677e11d34256599dd9d03 /app-editors/xemacs
parentppc stable profile (diff)
downloadhistorical-2c967bc19e39dbe97ddaaed2ebb3b161146836d3.tar.gz
historical-2c967bc19e39dbe97ddaaed2ebb3b161146836d3.tar.bz2
historical-2c967bc19e39dbe97ddaaed2ebb3b161146836d3.zip
I accidentally added a new version, only tested on ppc over an already existing version. My bad, sorry. -r1 is the revision before my changes, also tested on ppc now
Diffstat (limited to 'app-editors/xemacs')
-rw-r--r--app-editors/xemacs/Manifest4
-rw-r--r--app-editors/xemacs/files/digest-xemacs-21.4.15-r12
-rw-r--r--app-editors/xemacs/xemacs-21.4.15-r1.ebuild191
3 files changed, 196 insertions, 1 deletions
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 1dc5d4f9a9ce..0bd8ba3fbabc 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -2,7 +2,8 @@ MD5 b5a662bef1b30c63aebe5d430c66dbab ChangeLog 8493
MD5 0f39d0139849956930b1a500aca9c6de metadata.xml 365
MD5 e575bd3c0a8ac4756e3bb8b118c525ef xemacs-21.4.12.ebuild 4944
MD5 cd336f54fb85ddaeaf1a46bda0909ddb xemacs-21.4.9.ebuild 4175
-MD5 fe7de2c7f59e13eca7ad4ed3ce5f848e xemacs-21.4.15.ebuild 4165
+MD5 0851d9f93b92221bab351c17dc2668f8 xemacs-21.4.15-r1.ebuild 5046
+MD5 f4d3bb625a82d5a7948445d8db7fbdfd xemacs-21.4.15.ebuild 5043
MD5 df382940daa67bb8888fbae22d617cb4 files/README.Gentoo 1426
MD5 6d3780dc77d3dd7c017d8864d2f0b07d files/digest-xemacs-21.4.12 130
MD5 70d163ee0eb6f3a0aaa7c0ddccd6a3d7 files/digest-xemacs-21.4.15 204
@@ -14,3 +15,4 @@ MD5 39fc9657b72b09c8b91f52ee50758ad2 files/xemacs-21.4.12-ppc.diff 1075
MD5 94beef92edcaf12edef657556fbb7a7e files/xemacs-21.4.8-ppc.diff 1032
MD5 678239bc0954d838f5a9c53a6570c850 files/xemacs-21.4.9-ppc-glibc-2.3.x.diff 1112
MD5 c72c4643e7b5e7c44a57766a88838600 files/xemacs-21.4.9-ppc.diff 1031
+MD5 6a3d383a050855607a702a56c850ff1a files/digest-xemacs-21.4.15-r1 130
diff --git a/app-editors/xemacs/files/digest-xemacs-21.4.15-r1 b/app-editors/xemacs/files/digest-xemacs-21.4.15-r1
new file mode 100644
index 000000000000..daf9ca3600d6
--- /dev/null
+++ b/app-editors/xemacs/files/digest-xemacs-21.4.15-r1
@@ -0,0 +1,2 @@
+MD5 b80e040d9cb85c9210999554dc210fa6 xemacs-21.4.15.tar.gz 10652161
+MD5 95c531ec2639990a09e92c59a855784e NeXT_XEmacs.tar.gz 39571
diff --git a/app-editors/xemacs/xemacs-21.4.15-r1.ebuild b/app-editors/xemacs/xemacs-21.4.15-r1.ebuild
new file mode 100644
index 000000000000..181e94494288
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.4.15-r1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.15-r1.ebuild,v 1.1 2004/08/20 14:54:00 pvdabeel Exp $
+
+inherit eutils
+
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
+SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ppc ~sparc ~alpha ~amd64 ppc64"
+IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
+
+# esound is know to cause problems in XEmacs
+#esd? ( media-sound/esound )
+RDEPEND="virtual/libc
+ !virtual/xemacs
+
+ berkdb? ( =sys-libs/db-1* >=sys-libs/gdbm-1.8.0 )
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6
+ >=media-libs/audiofile-0.2.3
+
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+
+ postgres? ( >=dev-db/postgresql-7.2 )
+ ldap? ( net-nds/openldap )
+
+ nas? ( media-libs/nas )
+
+ dnd? ( x11-libs/dnd )
+
+ X? ( virtual/x11 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ athena? ( virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ neXt? ( x11-libs/neXtaw )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff )
+ png? ( =media-libs/libpng-1.2* )
+ jpeg? ( media-libs/jpeg )
+
+ canna? ( app-i18n/canna )
+ !amd64? ( freewnn? ( app-i18n/freewnn ) )"
+DEPEND="${RDEPEND}
+ >=sys-libs/ncurses-5.2"
+PDEPEND="app-xemacs/xemacs-base
+ mule? app-xemacs/mule-base"
+PROVIDE="virtual/xemacs virtual/editor"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack NeXT_XEmacs.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/emodules.info-21.4.8-gentoo.patch
+
+ epatch ${FILESDIR}/quick-fix.patch
+ # copy Next_XEmacs icons into toolbar dir
+ cp ${WORKDIR}/NeXT.XEmacs/xemacs-icons/* ${S}/etc/toolbar/
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+
+ myconf="--with-widgets=lucid"
+ myconf="${myconf} --with-dialogs=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ myconf="${myconf} --with-menubars=lucid"
+ if use motif ; then
+ myconf="--with-widgets=motif"
+ myconf="${myconf} --with-dialogs=motif"
+ myconf="${myconf} --with-scrollbars=motif"
+ myconf="${myconf} --with-menubars=lucid"
+ fi
+ if use athena ; then
+ myconf="--with-widgets=athena"
+ if use Xaw3d ; then
+ myconf="${myconf} --with-athena=xaw3d"
+ elif use neXt ; then
+ myconf="${myconf} --with-athena=next"
+ else
+ myconf="${myconf} --with-athena=3d"
+ fi
+ myconf="${myconf} --with-dialogs=athena"
+ myconf="${myconf} --with-scrollbars=lucid"
+ myconf="${myconf} --with-menubars=lucid"
+ fi
+
+ myconf="${myconf}
+ --with-gif=no"
+
+ use dnd && myconf="${myconf} --with-dragndrop --with-offix"
+
+ use tiff && myconf="${myconf} --with-tiff" ||
+ myconf="${myconf} --without-tiff"
+ use png && myconf="${myconf} --with-png" ||
+ myconf="${myconf} --without-png"
+ use jpeg && myconf="${myconf} --with-jpeg" ||
+ myconf="${myconf} --without-jpeg"
+ use xface && myconf="${myconf} --with-xface" ||
+ myconf="${myconf} --without-xface"
+
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-gif=no"
+ fi
+
+ use gpm && myconf="${myconf} --with-gpm" ||
+ myconf="${myconf} --without-gpm"
+ use postgres && myconf="${myconf} --with-postgresql" ||
+ myconf="${myconf} --without-postgresql"
+ use ldap && myconf="${myconf} --with-ldap" ||
+ myconf="${myconf} --without-ldap"
+
+ if use mule ; then
+ myconf="${myconf} --with-mule"
+ use motif && myconf="${myconf} --with-xim=motif" ||
+ myconf="${myconf} --with-xim=xlib"
+ use canna && myconf="${myconf} --with-canna" ||
+ myconf="${myconf} --without-canna"
+ use freewnn && myconf="${myconf} --with-wnn" ||
+ myconf="${myconf} --without-wnn"
+ fi
+
+ local soundconf="native"
+
+ use nas && soundconf="${soundconf},nas"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ local dbconf="gnudbm"
+ if use berkdb; then
+ myconf="${myconf} --with-database=${dbconf}"
+ else
+ myconf="${myconf} --without-database"
+ fi
+
+ # fixes #21264
+ use alpha && myconf="${myconf} --with-system-malloc"
+
+ use ppc64 && myconf="${myconf} --with-system-malloc"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --with-pop \
+ --with-ncurses \
+ --with-msw=no \
+ --mail-locking=flock \
+ --with-site-lisp=yes \
+ --with-site-modules=yes \
+ || die
+
+ # emake dont work on faster boxes it seems
+ # azarah (04 Aug 2002)
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ infodir=${D}/usr/share/info \
+ install gzip-el || die
+
+ # install base packages directories
+ dodir /usr/lib/xemacs/xemacs-packages/
+ dodir /usr/lib/xemacs/site-packages/
+ dodir /usr/lib/xemacs/site-modules/
+ dodir /usr/lib/xemacs/site-lisp/
+
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ fi
+
+ # remove extraneous files
+ cd ${D}/usr/share/info
+ rm -f dir info.info texinfo* termcap*
+ cd ${S}
+ dodoc BUGS CHANGES-* ChangeLog GETTING* INSTALL PROBLEMS README*
+ dodoc ${FILESDIR}/README.Gentoo
+ rm -f ${D}/usr/share/info/emodules.info~*
+}