summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-10 23:01:05 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-10 23:01:05 +0000
commitaf002ccf643d865811d45a0ba8a77e97a98feea9 (patch)
tree64c328a76968a88895a7010cdfca37d77368408d /app-misc/hexcompare
parentMove into ~arch. (diff)
downloadhistorical-af002ccf643d865811d45a0ba8a77e97a98feea9.tar.gz
historical-af002ccf643d865811d45a0ba8a77e97a98feea9.tar.bz2
historical-af002ccf643d865811d45a0ba8a77e97a98feea9.zip
Initial import
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-misc/hexcompare')
-rw-r--r--app-misc/hexcompare/ChangeLog10
-rw-r--r--app-misc/hexcompare/Manifest5
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.1.patch52
-rw-r--r--app-misc/hexcompare/hexcompare-1.0.1.ebuild38
-rw-r--r--app-misc/hexcompare/metadata.xml10
5 files changed, 115 insertions, 0 deletions
diff --git a/app-misc/hexcompare/ChangeLog b/app-misc/hexcompare/ChangeLog
new file mode 100644
index 000000000000..3cdc591d6cd4
--- /dev/null
+++ b/app-misc/hexcompare/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/hexcompare
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hexcompare/ChangeLog,v 1.1 2010/11/10 23:01:05 xmw Exp $
+
+*hexcompare-1.0.1 (10 Nov 2010)
+
+ 10 Nov 2010; Michael Weber <xmw@gentoo.org> +hexcompare-1.0.1.ebuild,
+ +files/hexcompare-1.0.1.patch, +metadata.xml:
+ Initial import, fixes bug #344981, thanks to Alec Moskvin for the report.
+
diff --git a/app-misc/hexcompare/Manifest b/app-misc/hexcompare/Manifest
new file mode 100644
index 000000000000..a4b57bd61811
--- /dev/null
+++ b/app-misc/hexcompare/Manifest
@@ -0,0 +1,5 @@
+AUX hexcompare-1.0.1.patch 1491 RMD160 5401cd5ff60a761c1402540389b862d0394b83af SHA1 bdff7f9e096be1e20c27fb5f8b6a554181b0ff1b SHA256 3427b3b7f377d3b8a6c1c1247b371ede3794a4f0d1b18456e8f2ba1f09359e6d
+DIST hexcompare-101.tar.gz 8718 RMD160 6b94c67db95c9f99d9d6ca4da2a5d9a1a2044211 SHA1 d95740b1de89ff3c7501d64084f3cc9db6c122ee SHA256 3aad559a1784aacd315109ebad47ab99364ad8c9ab6410463f3d457d5d7e7e76
+EBUILD hexcompare-1.0.1.ebuild 887 RMD160 e3c95607a35e02374b3a065361e42648aaf7286d SHA1 a8840d10f1de099c9f85c7130bb2a15b0d6e9695 SHA256 f795aa75d25b2c2f66463b1bec253091bcda4fcdad8272bd9bc9e67f9aaa959a
+MISC ChangeLog 438 RMD160 37893604d738d695012cf6710f4a3e2ff3b4cd85 SHA1 d6c62488b4490e10ad6f225849469b7680f13b1f SHA256 45d466c74dec990807e49a4fb3c9bed7fea7aacc1a3a4168beccf3d0882ce4b6
+MISC metadata.xml 245 RMD160 6b03982a4d5f32d9fa6b9259ae36f9fcb07c8404 SHA1 fb16c7b4c5ab071dd979f761b8bb075f5396b737 SHA256 375a1da02cd2c393ce2378a73c1ce08134bc030b3bb378c6a4d6ca9cd5be1f8d
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.1.patch b/app-misc/hexcompare/files/hexcompare-1.0.1.patch
new file mode 100644
index 000000000000..8971a5e2c703
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.1.patch
@@ -0,0 +1,52 @@
+--- hexcompare-101/gui.c
++++ hexcompare-101/gui.c
+@@ -39,7 +39,7 @@
+ {
+ // With a given offset, calculate which element it corresponds to
+ // in the offset_index.
+- int i, current_block;
++ int i, current_block = 0;
+ for (i = 0; i < total_blocks; i++) {
+
+ // Go block by block, and see if our offset is greater than
+@@ -62,7 +62,7 @@
+ char offset_query[32];
+ char offset_line[32];
+ int offset_size = 0;
+- int previous_size, current_size, i;
++ int previous_size, current_size = 0, i;
+ int redo_loop = false;
+
+ // Endless loop until we figure out an offset size that is constant
+@@ -533,10 +533,6 @@
+
+ // Create variables.
+ int i, j;
+- bool active_declared = false;
+- int offset_string_length = 0;
+- unsigned long temp_offset;
+- char offset_line[32];
+
+ // Define colors block diagram.
+ init_pair(BLOCK_SAME, COLOR_WHITE, COLOR_BLUE);
+@@ -621,12 +617,6 @@
+ //
+ //
+
+- // Create variables.
+- int i, j;
+- bool active_declared = false;
+- int offset_string_length = 0;
+- unsigned long temp_offset;
+-
+ // Define colors block diagram.
+ init_pair(BLOCK_SAME, COLOR_WHITE, COLOR_BLUE);
+ init_pair(BLOCK_DIFFERENT, COLOR_WHITE, COLOR_RED);
+@@ -753,7 +743,6 @@
+ while((key_pressed = wgetch(main_window)) != 'q')
+ {
+ int rows;
+- int bytes_per_row = (width - SIDE_MARGIN*2) * bytes_per_block;
+ if (mode == OVERVIEW_MODE) rows = 5; else rows = height - 5;
+
+ switch(key_pressed)
diff --git a/app-misc/hexcompare/hexcompare-1.0.1.ebuild b/app-misc/hexcompare/hexcompare-1.0.1.ebuild
new file mode 100644
index 000000000000..e22501d161fc
--- /dev/null
+++ b/app-misc/hexcompare/hexcompare-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hexcompare/hexcompare-1.0.1.ebuild,v 1.1 2010/11/10 23:01:05 xmw Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="ncurses-based visual comparison of binary files"
+HOMEPAGE="http://hexcompare.sourceforge.net/"
+MY_P=${PN}-$(replace_all_version_separators '')
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} $(/usr/bin/ncurses5-config --cflags) \
+ -o ${PN} main.c gui.c \
+ ${LDFLAGS} $(/usr/bin/ncurses5-config --libs) || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README || die
+}
diff --git a/app-misc/hexcompare/metadata.xml b/app-misc/hexcompare/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/app-misc/hexcompare/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+