summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-14 19:04:53 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-14 19:04:53 +0000
commit1e56959662a604d8d2b295103767e1ee331c70da (patch)
treeb57aa6227680b7b449431e40735a4c9f048edc93 /app-text/ronn
parentInitial import. Dependency of app-text/ronn. (diff)
downloadhistorical-1e56959662a604d8d2b295103767e1ee331c70da.tar.gz
historical-1e56959662a604d8d2b295103767e1ee331c70da.tar.bz2
historical-1e56959662a604d8d2b295103767e1ee331c70da.zip
Initial import. Dependency of dev-ruby/bundler.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-text/ronn')
-rw-r--r--app-text/ronn/ChangeLog10
-rw-r--r--app-text/ronn/Manifest14
-rw-r--r--app-text/ronn/metadata.xml5
-rw-r--r--app-text/ronn/ronn-0.7.3.ebuild35
4 files changed, 64 insertions, 0 deletions
diff --git a/app-text/ronn/ChangeLog b/app-text/ronn/ChangeLog
new file mode 100644
index 000000000000..bd2c8720b6e8
--- /dev/null
+++ b/app-text/ronn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/ronn
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.1 2010/09/14 19:04:53 graaff Exp $
+
+*ronn-0.7.3 (14 Sep 2010)
+
+ 14 Sep 2010; Hans de Graaff <graaff@gentoo.org> +ronn-0.7.3.ebuild,
+ +metadata.xml:
+ Initial import. Dependency of dev-ruby/bundler.
+
diff --git a/app-text/ronn/Manifest b/app-text/ronn/Manifest
new file mode 100644
index 000000000000..c943c9517a55
--- /dev/null
+++ b/app-text/ronn/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST ronn-0.7.3.gem 61440 RMD160 2b9b7cce3a81dd20971823cb401f5894e3498c92 SHA1 e30936a7e93204a81dd84fc0bff283b645fa1c29 SHA256 82df6fd4a3aa91734866710d2811a6387e50a7513fc528ce6c7d95ee7ad7f41e
+EBUILD ronn-0.7.3.ebuild 738 RMD160 0da4287e5fe00c904c4027261201d3fc09324abe SHA1 72606d1ba82a1355ba0f8e6319fa0fce521e64b2 SHA256 c97083c05aa1678ca63d3bbb6524053fcbb5a42c197dfed9f3eb49a53ee6be5a
+MISC ChangeLog 364 RMD160 7ac1b0279cc8588f1be987de571fa3d169653624 SHA1 f9de4d3277fd14f0ec719fa5af07169859fe81ba SHA256 33611b28d73441ade1e9c71a6b496a4a3378dee5cadf892f6dc460b6bc53c0ab
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iF4EAREIAAYFAkyPx1oACgkQZihJkut28Su93wEAoA3NsoOqAFi2t9l/8JhP+qP3
+LrxADsumYpyC9of7M/gA/AmrG2pVkgDGVTtUV+lAf5N0pqbe1HGI2ABLGhVppnRo
+=tN8r
+-----END PGP SIGNATURE-----
diff --git a/app-text/ronn/metadata.xml b/app-text/ronn/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/app-text/ronn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/app-text/ronn/ronn-0.7.3.ebuild b/app-text/ronn/ronn-0.7.3.ebuild
new file mode 100644
index 000000000000..31fa749ca1a4
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3.ebuild,v 1.1 2010/09/14 19:04:53 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES INSTALLING README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://foo.bar.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}