summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-03-28 23:35:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-03-28 23:35:27 +0000
commitbc6a68e1fa79a7f60835c841936b76d096d9501f (patch)
tree7fd1585d97b56026ef0367ab85551e3c0c2f2f12 /dev-cpp/Ice
parentCompiles fine, readding ~amd64 (diff)
downloadhistorical-bc6a68e1fa79a7f60835c841936b76d096d9501f.tar.gz
historical-bc6a68e1fa79a7f60835c841936b76d096d9501f.tar.bz2
historical-bc6a68e1fa79a7f60835c841936b76d096d9501f.zip
Version bump, bump to EAPI=2 for use dep
Package-Manager: portage-2.1.6.9/cvs/Linux i686
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/ChangeLog10
-rw-r--r--dev-cpp/Ice/Ice-3.3.1.ebuild69
-rw-r--r--dev-cpp/Ice/files/Ice-3.3.1-Makefile.patch68
3 files changed, 145 insertions, 2 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 00c44fdea3b0..7fbb61b746dc 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/Ice
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.18 2008/12/17 21:58:29 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.19 2009/03/28 23:35:27 caleb Exp $
+
+*Ice-3.3.1 (28 Mar 2009)
+
+ 28 Mar 2009; Caleb Tennis <caleb@gentoo.org>
+ +files/Ice-3.3.1-Makefile.patch, +Ice-3.3.1.ebuild:
+ Version bump
17 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+files/Ice-3.2.1-gcc43.patch, Ice-3.2.1.ebuild:
diff --git a/dev-cpp/Ice/Ice-3.3.1.ebuild b/dev-cpp/Ice/Ice-3.3.1.ebuild
new file mode 100644
index 000000000000..8489c3d0905c
--- /dev/null
+++ b/dev-cpp/Ice/Ice-3.3.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.3.1.ebuild,v 1.1 2009/03/28 23:35:27 caleb Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses test debug"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.4
+ >=dev-libs/openssl-0.9.8g
+ =sys-libs/db-4.6.21*[-nocxx]
+ =dev-cpp/libmcpp-2.7.2"
+
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( >=dev-lang/python-2.4 )"
+
+S=${WORKDIR}/${P}/cpp
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ MAKE_RULES="${S}/config/Make.rules"
+
+ #if use amd64; then
+ # sed -i -e "s:^#LP64:LP64:g" "${MAKE_RULES}" \
+ # || die "Failed to set lib64 directory"
+ #fi
+
+ if ! use ncurses; then
+ sed -i -e "s#^USE_READLINE.*#USE_READLINE ?= yes#g" \
+ "${MAKE_RULES}" || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ "${MAKE_RULES}" || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ "${MAKE_RULES}.Linux" || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ cp -dpR "${S}"/../slice "${D}"/usr/share/Ice
+}
+
+src_test() {
+ emake test || die "Test failed"
+}
diff --git a/dev-cpp/Ice/files/Ice-3.3.1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.3.1-Makefile.patch
new file mode 100644
index 000000000000..ceeaab4fd48e
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.3.1-Makefile.patch
@@ -0,0 +1,68 @@
+--- config/Make.rules.orig 2008-05-21 13:39:46.000000000 -0400
++++ config/Make.rules 2008-05-21 13:43:35.000000000 -0400
+@@ -11,13 +11,13 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= /$(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -144,10 +144,10 @@
+ include $(top_srcdir)/config/Make.rules.$(UNAME)
+
+ install_includedir := $(prefix)/include
+-install_docdir := $(prefix)/doc
++install_docdir := $(prefix)/share/doc/Ice-$(VERSION)
+ install_bindir := $(prefix)/$(binsubdir)
+ install_libdir := $(prefix)/$(libsubdir)
+-install_configdir := $(prefix)/config
++install_configdir := $(prefix)/share/Ice/config
+
+ ifneq ($(embedded_runpath_prefix),)
+ runpath_libdir := $(embedded_runpath_prefix)/$(libsubdir)
+@@ -162,18 +162,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+-else
+- ifeq ($(shell if [ -d /usr/include/db46 -a -d /usr/$(libsubdir)/db46 ] ; then echo yes; fi), yes)
+- DB_FLAGS = -I/usr/include/db46
+- DB_LIBS = -L/usr/$(libsubdir)/db46 -ldb_cxx
+- else
+- DB_LIBS = -ldb_cxx
+- endif
+-endif
++DB_FLAGS = -I/usr/include/db4.6
++DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.6
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+ EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
+--- Makefile.orig 2008-05-21 13:42:32.000000000 -0400
++++ Makefile 2008-05-21 13:42:50.000000000 -0400
+@@ -11,11 +11,11 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo
++SUBDIRS = config src include
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_configdir)
+
+-install:: install-common
++install::
+ @for subdir in $(INSTALL_SUBDIRS); \
+ do \
+ if test ! -d $$subdir ; \