summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-27 17:52:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-27 17:52:39 +0000
commit18505bd5d7f565409e3700961fd8ab8d5ba1a244 (patch)
tree70c96806b3b3dca64a9180eb4c6aca19a1e64f7a /dev-ml
parentversion bump (diff)
downloadhistorical-18505bd5d7f565409e3700961fd8ab8d5ba1a244.tar.gz
historical-18505bd5d7f565409e3700961fd8ab8d5ba1a244.tar.bz2
historical-18505bd5d7f565409e3700961fd8ab8d5ba1a244.zip
initial import, thanks to Bardur Arantsson <bugs-gentoo.org@scientician.net>, bug #96384
Package-Manager: portage-2.1.4
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ANSITerminal/ANSITerminal-0.3.ebuild43
-rw-r--r--dev-ml/ANSITerminal/ChangeLog11
-rw-r--r--dev-ml/ANSITerminal/Manifest26
-rw-r--r--dev-ml/ANSITerminal/files/digest-ANSITerminal-0.33
-rw-r--r--dev-ml/ANSITerminal/metadata.xml5
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-ml/ANSITerminal/ANSITerminal-0.3.ebuild b/dev-ml/ANSITerminal/ANSITerminal-0.3.ebuild
new file mode 100644
index 000000000000..0ad023c515a9
--- /dev/null
+++ b/dev-ml/ANSITerminal/ANSITerminal-0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ANSITerminal/ANSITerminal-0.3.ebuild,v 1.1 2008/01/27 17:52:38 aballier Exp $
+
+EAPI=1
+
+inherit findlib eutils
+
+DESCRIPTION="Module which offers basic control of ANSI compliant terminals"
+HOMEPAGE="http://math.umh.ac.be/an/software.php#x4-80007"
+SRC_URI="ftp://ftp.umh.ac.be/pub/ftp_san/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+DEPEND="dev-lang/ocaml"
+IUSE="doc +ocamlopt"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ emake byte || die "Failed to compile bytecode"
+ if use ocamlopt; then
+ emake opt || die "Failed to compile native code"
+ else
+ sed -i -e "s/all META/byte META/" Makefile || die "failed to make native code optional"
+ fi
+ if use doc; then
+ emake doc || die "Failed to build documentation"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+ use doc && dohtml ANSITerminal.html/*
+}
diff --git a/dev-ml/ANSITerminal/ChangeLog b/dev-ml/ANSITerminal/ChangeLog
new file mode 100644
index 000000000000..d999daf45a03
--- /dev/null
+++ b/dev-ml/ANSITerminal/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ANSITerminal
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ANSITerminal/ChangeLog,v 1.1 2008/01/27 17:52:38 aballier Exp $
+
+*ANSITerminal-0.3 (27 Jan 2008)
+
+ 27 Jan 2008; Alexis Ballier <aballier@gentoo.org> +metadata.xml,
+ +ANSITerminal-0.3.ebuild:
+ initial import, thanks to Bardur Arantsson
+ <bugs-gentoo.org@scientician.net>, bug #96384
+
diff --git a/dev-ml/ANSITerminal/Manifest b/dev-ml/ANSITerminal/Manifest
new file mode 100644
index 000000000000..cb7b6cb0ed51
--- /dev/null
+++ b/dev-ml/ANSITerminal/Manifest
@@ -0,0 +1,26 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST ANSITerminal-0.3.tar.bz2 14697 RMD160 381dac33989cd20945c8023c54ea3931cb49bbc6 SHA1 83686fb5a572ce6c395b2cedcdf82dd9c506d3bb SHA256 727be52ffb49ebe6221bdcb83d00a80ab7c1d0e4f62599efba1db28c4ae12b60
+EBUILD ANSITerminal-0.3.ebuild 1308 RMD160 7ff8de32458862e995135395440dc53233bb335f SHA1 900153b6745986ef78a6a1dcb40a0907faf45a85 SHA256 7196b5d9cae68edbad41f064bf22b6fd579fd00911a3caf58204d7e8c78d5c7b
+MD5 acd374638295df754b21d051b79b181c ANSITerminal-0.3.ebuild 1308
+RMD160 7ff8de32458862e995135395440dc53233bb335f ANSITerminal-0.3.ebuild 1308
+SHA256 7196b5d9cae68edbad41f064bf22b6fd579fd00911a3caf58204d7e8c78d5c7b ANSITerminal-0.3.ebuild 1308
+MISC ChangeLog 435 RMD160 48edd839bb39f3f0b02c996019a3d3a96e482ef2 SHA1 c15c0cc24a00e487c9cd4af734c36bd73a65d5cb SHA256 dc0e6843fb06d125d708b45721aaff6d66c3324308a5e16f59703eca9fec2c2e
+MD5 96b0a2a2f5942dc188d841c3b2281b3b ChangeLog 435
+RMD160 48edd839bb39f3f0b02c996019a3d3a96e482ef2 ChangeLog 435
+SHA256 dc0e6843fb06d125d708b45721aaff6d66c3324308a5e16f59703eca9fec2c2e ChangeLog 435
+MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
+RMD160 dfaa057e679b01302a807c75a32a910098b26809 metadata.xml 155
+SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81 metadata.xml 155
+MD5 55c5dc1b973948da45ceb39bab5bf104 files/digest-ANSITerminal-0.3 250
+RMD160 a1c8b566f6914459181a5e0fc9f072b6b011fc52 files/digest-ANSITerminal-0.3 250
+SHA256 005a427e41e806d7e4eab022c9bac88e90a6c2af3f1cf0bfbc6774868924bb08 files/digest-ANSITerminal-0.3 250
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFHnMTwvFcC4BYPU0oRAjrqAJ4o8ZDBg9g/8cA67XZdF10phAxThACgq7y/
+PHJbX86ZEB1314MfrCsRaUg=
+=7PoJ
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/ANSITerminal/files/digest-ANSITerminal-0.3 b/dev-ml/ANSITerminal/files/digest-ANSITerminal-0.3
new file mode 100644
index 000000000000..b0bb1eaac908
--- /dev/null
+++ b/dev-ml/ANSITerminal/files/digest-ANSITerminal-0.3
@@ -0,0 +1,3 @@
+MD5 33efee4b57658ee07b6c17411bab7c66 ANSITerminal-0.3.tar.bz2 14697
+RMD160 381dac33989cd20945c8023c54ea3931cb49bbc6 ANSITerminal-0.3.tar.bz2 14697
+SHA256 727be52ffb49ebe6221bdcb83d00a80ab7c1d0e4f62599efba1db28c4ae12b60 ANSITerminal-0.3.tar.bz2 14697
diff --git a/dev-ml/ANSITerminal/metadata.xml b/dev-ml/ANSITerminal/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ANSITerminal/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>