summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-08 12:21:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-08 12:21:59 +0000
commitcfb8099e0de2c463cd8461f30ad3e9756cd772aa (patch)
tree7c973abcaaadd31b6637239b1497eee98687dd55 /dev-ml
parentremove old (diff)
downloadhistorical-cfb8099e0de2c463cd8461f30ad3e9756cd772aa.tar.gz
historical-cfb8099e0de2c463cd8461f30ad3e9756cd772aa.tar.bz2
historical-cfb8099e0de2c463cd8461f30ad3e9756cd772aa.zip
version bump
Package-Manager: portage-2.2.0_alpha135/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-expect/ChangeLog7
-rw-r--r--dev-ml/ocaml-expect/ocaml-expect-0.0.3.ebuild26
-rw-r--r--dev-ml/ocaml-text/ChangeLog7
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.6.ebuild30
4 files changed, 68 insertions, 2 deletions
diff --git a/dev-ml/ocaml-expect/ChangeLog b/dev-ml/ocaml-expect/ChangeLog
index 4e7473579a63..c5db5ad93bc3 100644
--- a/dev-ml/ocaml-expect/ChangeLog
+++ b/dev-ml/ocaml-expect/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-expect
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expect/ChangeLog,v 1.2 2012/03/27 21:10:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expect/ChangeLog,v 1.3 2012/10/08 12:21:59 aballier Exp $
+
+*ocaml-expect-0.0.3 (08 Oct 2012)
+
+ 08 Oct 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-expect-0.0.3.ebuild:
+ version bump
27 Mar 2012; Alexis Ballier <aballier@gentoo.org> ocaml-expect-0.0.2.ebuild:
convert to oasis.eclass
diff --git a/dev-ml/ocaml-expect/ocaml-expect-0.0.3.ebuild b/dev-ml/ocaml-expect/ocaml-expect-0.0.3.ebuild
new file mode 100644
index 000000000000..421235de8a74
--- /dev/null
+++ b/dev-ml/ocaml-expect/ocaml-expect-0.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expect/ocaml-expect-0.0.3.ebuild,v 1.1 2012/10/08 12:21:59 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Ocaml implementation of expect to help building unitary testing"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-expect/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/894/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/extlib
+ dev-ml/pcre-ocaml"
+DEPEND="${RDEPEND}
+ dev-ml/ounit"
+
+DOCS=( "README.txt" "CHANGES.txt" "AUTHORS.txt" )
diff --git a/dev-ml/ocaml-text/ChangeLog b/dev-ml/ocaml-text/ChangeLog
index 6260de8e87c1..98dfc778fa6a 100644
--- a/dev-ml/ocaml-text/ChangeLog
+++ b/dev-ml/ocaml-text/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-text
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ChangeLog,v 1.1 2012/03/28 11:37:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ChangeLog,v 1.2 2012/10/08 12:18:28 aballier Exp $
+
+*ocaml-text-0.6 (08 Oct 2012)
+
+ 08 Oct 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-text-0.6.ebuild:
+ version bump
*ocaml-text-0.5 (28 Mar 2012)
diff --git a/dev-ml/ocaml-text/ocaml-text-0.6.ebuild b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
new file mode 100644
index 000000000000..48abb35645d7
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ocaml-text-0.6.ebuild,v 1.1 2012/10/08 12:18:28 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/937/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+DEPEND="virtual/libiconv
+ pcre? ( dev-ml/pcre-ocaml[ocamlopt?] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "CHANGES" "CHANGES.darcs" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}