summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-04-08 16:41:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-04-08 16:41:05 +0000
commit208385c3921c713e15171930a0de05463608a07e (patch)
tree8b843d232837a107b196f2964d0644eaf1f536f4 /games-action/luola/luola-1.3.0-r1.ebuild
parentAdding package.mask for baselayout-vserver-1.12.0_pre17 (only for testing pur... (diff)
downloadhistorical-208385c3921c713e15171930a0de05463608a07e.tar.gz
historical-208385c3921c713e15171930a0de05463608a07e.tar.bz2
historical-208385c3921c713e15171930a0de05463608a07e.zip
rev bump to pull in two upstream patches
Package-Manager: portage-2.1_pre7-r4
Diffstat (limited to 'games-action/luola/luola-1.3.0-r1.ebuild')
-rw-r--r--games-action/luola/luola-1.3.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-action/luola/luola-1.3.0-r1.ebuild b/games-action/luola/luola-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..702e70af56cc
--- /dev/null
+++ b/games-action/luola/luola-1.3.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0-r1.ebuild,v 1.1 2006/04/08 16:41:05 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
+HOMEPAGE="http://luolamies.org/software/luola/"
+PATCHES="http://luolamies.org/software/luola/luola-1.3.0-1.patch
+ http://luolamies.org/software/luola/luola-1.3.0-2.patch"
+SRC_URI="http://luolamies.org/software/luola/${P}.tar.gz
+ http://www.luolamies.org/software/luola/stdlevels-5.2.tar.gz
+ http://www.luolamies.org/software/luola/nostalgia-1.1.tar.gz
+ ${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+
+src_unpack() {
+ local p
+
+ unpack ${A}
+ cd "${S}/src"
+ for p in ${PATCHES}
+ do
+ epatch "${DISTDIR}/${p##*/}"
+ done
+}
+
+src_compile() {
+ egamesconf --enable-sound || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/levels
+ doins "${WORKDIR}"/*.{lev,png} || die "doins failed"
+ dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
+ RELEASENOTES.txt ../README.Nostalgia
+ newdoc ../README README.stdlevels
+ doicon luola.png
+ make_desktop_entry luola Luola
+ prepgamesdirs
+}