summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 08:29:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-19 08:29:29 +0000
commit9ac3284b6400f17323cd6c8a241b1d3b2d95db28 (patch)
treea313426cd8d707cead100951c45bd46f7fe914dc /games-simulation/senken
parentMarked ppc (diff)
downloadhistorical-9ac3284b6400f17323cd6c8a241b1d3b2d95db28.tar.gz
historical-9ac3284b6400f17323cd6c8a241b1d3b2d95db28.tar.bz2
historical-9ac3284b6400f17323cd6c8a241b1d3b2d95db28.zip
fix deps for bug #64599; tidy
Diffstat (limited to 'games-simulation/senken')
-rw-r--r--games-simulation/senken/ChangeLog5
-rw-r--r--games-simulation/senken/Manifest4
-rw-r--r--games-simulation/senken/senken-0.3.0.ebuild21
3 files changed, 17 insertions, 13 deletions
diff --git a/games-simulation/senken/ChangeLog b/games-simulation/senken/ChangeLog
index 9143ff28f5cb..fe8bae6c7375 100644
--- a/games-simulation/senken/ChangeLog
+++ b/games-simulation/senken/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/senken
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/ChangeLog,v 1.4 2004/06/24 23:23:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/ChangeLog,v 1.5 2004/09/19 08:29:29 mr_bones_ Exp $
+
+ 19 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> senken-0.3.0.ebuild:
+ fix deps for bug #64599; tidy
*senken-0.3.0 (06 Mar 2004)
diff --git a/games-simulation/senken/Manifest b/games-simulation/senken/Manifest
index 04d83fe50204..844f7def5b6a 100644
--- a/games-simulation/senken/Manifest
+++ b/games-simulation/senken/Manifest
@@ -1,6 +1,6 @@
+MD5 f2635789b060538124e5a30f312031f6 ChangeLog 767
MD5 5d71f897a044a4479c7a2847394bca18 senken-0.2.6.ebuild 1073
-MD5 b2ca6c5fecdfaeeb8a43a4104c358e69 ChangeLog 657
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 3e30857e6fe30a3d0e87d1fc30dc762d senken-0.3.0.ebuild 1273
+MD5 3b34b1351ef4123b5fec3264ce1c5d93 senken-0.3.0.ebuild 1317
MD5 bd89d6772450df2aeb99ff1213ec5ab4 files/digest-senken-0.2.6 65
MD5 f1875c2364dcc366833c7c888405013a files/digest-senken-0.3.0 65
diff --git a/games-simulation/senken/senken-0.3.0.ebuild b/games-simulation/senken/senken-0.3.0.ebuild
index 4eaa593f0476..115dba3d086b 100644
--- a/games-simulation/senken/senken-0.3.0.ebuild
+++ b/games-simulation/senken/senken-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.2 2004/06/24 23:23:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/senken/senken-0.3.0.ebuild,v 1.3 2004/09/19 08:29:29 mr_bones_ Exp $
inherit games
@@ -14,7 +14,7 @@ KEYWORDS="x86"
IUSE="nls"
RDEPEND="virtual/x11
- =x11-libs/gtk+-1*
+ >=x11-libs/gtk+-2
>=media-libs/libsdl-1.2.4
media-libs/sdl-image"
DEPEND="${RDEPEND}
@@ -22,14 +22,15 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S} && \
+ cd "${S}"
sed -i \
-e "s:/usr/local/share:${GAMES_DATADIR}:" \
- lib/utils.h || die "sed lib/utils.h failed"
+ lib/utils.h \
+ || die "sed lib/utils.h failed"
}
src_compile() {
- egamesconf `use_enable nls` || die
+ egamesconf $(use_enable nls) || die
emake || die "emake failed"
}
@@ -38,12 +39,12 @@ src_install() {
dodoc AUTHORS README TODO
dodir "${GAMES_DATADIR}"
- cd "${D}/${GAMES_PREFIX}"
- mv share/senken "${D}/${GAMES_DATADIR}/"
- rm -rf include lib man share
+ mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" \
+ || die "mv failed"
+ rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share}
- insinto ${GAMES_DATADIR}/senken/img
- doins ${S}/img/*.png
+ insinto "${GAMES_DATADIR}/senken/img"
+ doins img/*.png
find "${D}/${GAMES_DATADIR}/" -type f -exec chmod a-x \{\} \;
find "${D}/${GAMES_DATADIR}/" -name "Makefile.*" -exec rm -f \{\} \;