summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 21:50:30 +0000
commitd56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd (patch)
tree0e95f89e243b104e1a29dba27aede4970eb7c530 /kde-base/kwin
parentUSE minimal controls now headers wrt #315567. Scribus is no reverse depend of... (diff)
downloadhistorical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.gz
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.tar.bz2
historical-d56a49ac6fdf2ce7ddacc2a7acd2dff576228ebd.zip
Version bump KDE 4.4.3
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.4.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 8bae99b8302d..41c1e161620b 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.193 2010/03/31 23:16:36 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.194 2010/05/03 21:29:51 alexxy Exp $
+
+*kwin-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +kwin-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -kwin-4.3.4-r1.ebuild,
-kwin-4.4.0.ebuild:
diff --git a/kde-base/kwin/kwin-4.4.3.ebuild b/kde-base/kwin/kwin-4.4.3.ebuild
new file mode 100644
index 000000000000..f290dd4c51fa
--- /dev/null
+++ b/kde-base/kwin/kwin-4.4.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.4.3.ebuild,v 1.1 2010/05/03 21:29:51 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug xcomposite xinerama"
+
+# NOTE disabled for now: captury? ( media-libs/libcaptury )
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_prepare() {
+# NOTE uncomment when enabled again by upstream
+# if ! use captury; then
+# sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+# -i kwin/effects/CMakeLists.txt || \
+# die "Making captury optional failed."
+# fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}