summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commitaa66be86a5a6d313a757a8082822195e32ec6d44 (patch)
tree216e32b289318ecc6cc5c758e202354a9ced5982 /kde-base/okular
parentUse --with-optim to respect CFLAGS (bug #261214). (diff)
downloadhistorical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.gz
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.bz2
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.zip
[kde-base] Bump KDE SC 4.4.5 =)
Package-Manager: portage-2.2_rc67_p182/cvs/Linux x86_64
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.4.5.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 2f742be475af..5bcb70f34297 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.73 2010/06/28 03:25:59 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.74 2010/06/30 15:36:59 alexxy Exp $
+
+*okular-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.4.5.ebuild:
+ Version bump
28 Jun 2010; Christian Faulhammer <fauli@gentoo.org> okular-4.4.4.ebuild:
x86 stable, bug 322791
diff --git a/kde-base/okular/okular-4.4.5.ebuild b/kde-base/okular/okular-4.4.5.ebuild
new file mode 100644
index 000000000000..e7de5c4ef2e2
--- /dev/null
+++ b/kde-base/okular/okular-4.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.4.5.ebuild,v 1.1 2010/06/30 15:36:59 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +handbook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.12.3-r3[lcms,qt4] )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/mobipocket"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ insinto "${KDEDIR}"/share/apps/cmake/modules
+ doins "${S}"/cmake/modules/FindOkular.cmake
+
+ kde4-meta_src_install
+}