summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-03 20:08:11 +0000
commit5927f5c54422bdd7e485d04e5a5f7d18663ee66f (patch)
tree23ce069db9e32e9974c6b94cfa73af651ada1e7f /kde-base/perlqt
parentMask >ghc-7 on Tiger and Leopard (diff)
downloadhistorical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.gz
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.tar.bz2
historical-5927f5c54422bdd7e485d04e5a5f7d18663ee66f.zip
Version bump KDE SC 4.8.3
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.8.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index a9b8608bca2b..3f34bca281a4 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.29 2012/04/18 18:41:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.30 2012/05/03 20:07:46 johu Exp $
+
+*perlqt-4.8.3 (03 May 2012)
+
+ 03 May 2012; Johannes Huber <johu@gentoo.org> +perlqt-4.8.3.ebuild:
+ Version bump KDE SC 4.8.3
18 Apr 2012; Markus Meier <maekke@gentoo.org> perlqt-4.8.1.ebuild:
x86 stable, bug #409403
diff --git a/kde-base/perlqt/perlqt-4.8.3.ebuild b/kde-base/perlqt/perlqt-4.8.3.ebuild
new file mode 100644
index 000000000000..0e44035e0d85
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.8.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.8.3.ebuild,v 1.1 2012/05/03 20:07:46 johu Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+ "${FILESDIR}/${PN}-4.8.1-tests.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}