summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-15 19:35:12 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-15 19:35:12 +0000
commitdd049574f4a3cd7f2f5fa4ce5260acdc74a488d6 (patch)
tree72b459c7e699752a99fdb1385c657eada60f52fa /kde-misc/miniplayer/miniplayer-2.5.ebuild
parentRespect LINGUAS. Add missing dep. Remove old. (diff)
downloadhistorical-dd049574f4a3cd7f2f5fa4ce5260acdc74a488d6.tar.gz
historical-dd049574f4a3cd7f2f5fa4ce5260acdc74a488d6.tar.bz2
historical-dd049574f4a3cd7f2f5fa4ce5260acdc74a488d6.zip
Version bump.
Package-Manager: portage-2.2.0_alpha118/cvs/Linux x86_64
Diffstat (limited to 'kde-misc/miniplayer/miniplayer-2.5.ebuild')
-rw-r--r--kde-misc/miniplayer/miniplayer-2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-misc/miniplayer/miniplayer-2.5.ebuild b/kde-misc/miniplayer/miniplayer-2.5.ebuild
new file mode 100644
index 000000000000..582655c4c538
--- /dev/null
+++ b/kde-misc/miniplayer/miniplayer-2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/miniplayer/miniplayer-2.5.ebuild,v 1.1 2012/07/15 19:35:12 johu Exp $
+
+EAPI=4
+
+KDE_LINGUAS_DIR="applet/locale"
+KDE_LINGUAS="de et pl pt ru sv uk"
+inherit kde4-base
+
+DESCRIPTION="Multimedia player plasmoid"
+HOMEPAGE="http://kde-look.org/content/show.php?content=95501"
+SRC_URI="http://kde-look.org/CONTENT/content-files/95501-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ media-libs/phonon
+"
+RDEPEND="
+ ${DEPEND}
+ $(add_kdebase_dep plasma-workspace)
+"
+
+src_prepare() {
+ local lang
+ for lang in ${KDE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm ${KDE_LINGUAS_DIR}/${lang}.mo
+ fi
+ done
+
+ kde4-base_src_prepare
+}