summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-02-12 17:01:22 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-02-12 17:01:22 +0000
commit86bf6e279c1e718901f9e54ed0ff9316d3e749e7 (patch)
treefe3fba04fd2724609418da7826f7bc0866344526 /media-sound/rhythmbox
parentUse the proper menu icon (diff)
downloadhistorical-86bf6e279c1e718901f9e54ed0ff9316d3e749e7.tar.gz
historical-86bf6e279c1e718901f9e54ed0ff9316d3e749e7.tar.bz2
historical-86bf6e279c1e718901f9e54ed0ff9316d3e749e7.zip
Patch to make it compile with gcc-2. Copyright date fixes..
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/Manifest11
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch18
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild4
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.3.ebuild4
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.5.ebuild3
6 files changed, 35 insertions, 11 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index f835c87e7e16..2935e5d25546 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.27 2004/01/22 19:21:05 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.28 2004/02/12 17:01:22 leonardop Exp $
+
+ 12 Feb 2004; L. Boshell <leonardop@gentoo.org> rhythmbox-0.6.5.ebuild,
+ files/rhythmbox-0.6.5-gcc2_fix.patch:
+ Added patch to make it compile with gcc-2.
*rhythmbox-0.6.5 (22 Jan 2004)
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
index 64a84a278e57..5ca3ce7786e9 100644
--- a/media-sound/rhythmbox/Manifest
+++ b/media-sound/rhythmbox/Manifest
@@ -1,10 +1,11 @@
-MD5 affc921c48be44ff145fd5abf6962e0f ChangeLog 2633
-MD5 0000ad89422a8f895ae9288af9612dc6 rhythmbox-0.6.3.ebuild 1870
+MD5 93dad087aec638ead09e14c1511a009a ChangeLog 2795
+MD5 256a85d9c87c7e0220476881ff92b81c rhythmbox-0.6.3.ebuild 1874
MD5 59ce16aa65a6286a6dc804dbefb00769 rhythmbox-0.6.4.ebuild 1870
+MD5 38919d4ee7d0e0434ba4d8b67707e1fa rhythmbox-0.6.5.ebuild 1914
MD5 b263ff7675308d90b75a170acae3f5ff metadata.xml 177
-MD5 a1a1dc15a4b19d99bcdb071bca143c53 rhythmbox-0.6.1-r1.ebuild 1830
-MD5 db8a781c3f1f1fd842bfb6f5387d7298 rhythmbox-0.6.5.ebuild 1871
-MD5 5680d5f2fa4f98cf505fe60818d91e66 files/digest-rhythmbox-0.6.1-r1 69
+MD5 5843451693629f7002a374d366c9ca98 rhythmbox-0.6.1-r1.ebuild 1834
MD5 7860a0f4a2af30c021fc713e9ccef821 files/digest-rhythmbox-0.6.3 69
MD5 2452bf6909df1ece1e0ced39bd33c45b files/digest-rhythmbox-0.6.4 69
+MD5 5680d5f2fa4f98cf505fe60818d91e66 files/digest-rhythmbox-0.6.1-r1 69
MD5 9984afbb27959f877a164db744172cfd files/digest-rhythmbox-0.6.5 69
+MD5 6c5001723b759bda9528d5ebc03b470e files/rhythmbox-0.6.5-gcc2_fix.patch 637
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch b/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch
new file mode 100644
index 000000000000..0492f0765545
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.6.5-gcc2_fix.patch
@@ -0,0 +1,18 @@
+diff -NurB rhythmbox-0.6.5-orig/shell/rb-shell.c rhythmbox-0.6.5/shell/rb-shell.c
+--- rhythmbox-0.6.5-orig/shell/rb-shell.c 2004-02-12 11:34:12.000000000 -0500
++++ rhythmbox-0.6.5/shell/rb-shell.c 2004-02-12 11:34:45.000000000 -0500
+@@ -608,12 +608,13 @@
+ const CORBA_char *uri,
+ CORBA_Environment *ev)
+ {
++ GnomeVFSURI *vfsuri;
+ RBShell *shell = RB_SHELL (bonobo_object (_servant));
+ RBPlaylist *parser;
+
+ rb_debug ("handling uri: %s", uri);
+
+- GnomeVFSURI *vfsuri = gnome_vfs_uri_new (uri);
++ vfsuri = gnome_vfs_uri_new (uri);
+ if (!vfsuri) {
+ rb_error_dialog (_("Unable to parse URI \"%s\"\n"), uri);
+ return;
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
index 00aa0f01c012..a4c1145dcd9a 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.2 2003/12/23 14:19:36 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.3 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
index e44c8786ce07..6fe8bc6a77de 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild,v 1.1 2003/12/23 14:19:36 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.3.ebuild,v 1.2 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
index 09999650aa20..ac1fee6e33bb 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.1 2004/01/22 19:21:05 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.5.ebuild,v 1.2 2004/02/12 17:01:22 leonardop Exp $
inherit gnome2
@@ -61,6 +61,7 @@ src_unpack( ) {
# sandbox errors work around
gnome2_omf_fix ${S}/help/C/Makefile.in
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
}
DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \