summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-27 02:36:34 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-27 02:36:34 +0000
commitf834cf8f52d78f4076852e7480007790390ed33b (patch)
tree15e85dde21f0f41694a28df143a9f5f248df16f6 /net-misc/icecast
parentfixed SRC_URI and DEPEND problems (diff)
downloadhistorical-f834cf8f52d78f4076852e7480007790390ed33b.tar.gz
historical-f834cf8f52d78f4076852e7480007790390ed33b.tar.bz2
historical-f834cf8f52d78f4076852e7480007790390ed33b.zip
Added patch to fix new glibc errno issues #16370 (#16267)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog5
-rw-r--r--net-misc/icecast/files/1.3.12-errno.patch68
-rw-r--r--net-misc/icecast/icecast-1.3.12-r1.ebuild6
3 files changed, 75 insertions, 4 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index 4a645c872bf2..4c2228c83e17 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-misc/icecast
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.10 2003/02/12 12:34:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.11 2003/02/27 02:36:34 vapier Exp $
*icecast-1.3.12-r1 (23 Jul 2002)
+ 26 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch to fix new glibc errno issues #16370 (#16267).
+
12 Feb 2003; Seemant Kulleen <seemant@gentoo.org>
icecast-1.3.12-r1.ebuild files/variables.diff
files/icecast-1.3.12-variables-gentoo.diff.bz2 :
diff --git a/net-misc/icecast/files/1.3.12-errno.patch b/net-misc/icecast/files/1.3.12-errno.patch
new file mode 100644
index 000000000000..44c7af6fbfd7
--- /dev/null
+++ b/net-misc/icecast/files/1.3.12-errno.patch
@@ -0,0 +1,68 @@
+--- src/commands.c.orig 2003-02-26 21:24:19.000000000 -0500
++++ src/commands.c 2003-02-26 21:24:52.000000000 -0500
+@@ -85,7 +85,7 @@
+
+ #include <time.h>
+
+-extern int errno;
++#include <errno.h>
+ extern int running;
+ extern server_info_t info;
+ extern mutex_t library_mutex;
+--- src/ice_resolv.c.orig 2003-02-26 21:24:26.000000000 -0500
++++ src/ice_resolv.c 2003-02-26 21:25:10.000000000 -0500
+@@ -81,7 +81,7 @@
+ #ifdef _WIN32
+ extern int running;
+ #else
+-extern int h_errno, errno, running;
++#include <errno.h>
+ #endif
+
+ extern server_info_t info;
+--- src/log.c.orig 2003-02-26 21:24:30.000000000 -0500
++++ src/log.c 2003-02-26 21:26:33.000000000 -0500
+@@ -72,7 +72,8 @@
+ #include "authenticate/basic.h"
+ #include "authenticate/user.h"
+
+-extern int errno, running;
++#include <errno.h>
++extern int running;
+ extern server_info_t info;
+
+ void
+--- src/main.c.orig 2003-02-26 21:24:34.000000000 -0500
++++ src/main.c 2003-02-26 21:25:41.000000000 -0500
+@@ -97,7 +97,7 @@
+ #endif
+
+ /* We need this for perror and for various sanity checks */
+-extern int errno;
++#include <errno.h>
+
+ /* Importing a tree and mutex from sock.c */
+ extern avl_tree *sock_sockets;
+--- src/sock.c.orig 2003-02-26 21:24:37.000000000 -0500
++++ src/sock.c 2003-02-26 21:26:53.000000000 -0500
+@@ -87,7 +87,8 @@
+ #define read _read
+ extern int running;
+ #else
+-extern int h_errno, errno, running;
++#include <errno.h>
++extern int running;
+ #endif
+ extern server_info_t info;
+ extern struct in_addr localaddr;
+--- src/timer.c.orig 2003-02-26 21:24:40.000000000 -0500
++++ src/timer.c 2003-02-26 21:27:05.000000000 -0500
+@@ -79,7 +79,7 @@
+ #define MSG_DONTWAIT 0
+ #endif
+
+-extern int errno;
++#include <errno.h>
+ extern int running;
+ extern server_info_t info;
+
diff --git a/net-misc/icecast/icecast-1.3.12-r1.ebuild b/net-misc/icecast/icecast-1.3.12-r1.ebuild
index 494aff980f11..94046b42e888 100644
--- a/net-misc/icecast/icecast-1.3.12-r1.ebuild
+++ b/net-misc/icecast/icecast-1.3.12-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-1.3.12-r1.ebuild,v 1.5 2003/02/12 12:34:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-1.3.12-r1.ebuild,v 1.6 2003/02/27 02:36:34 vapier Exp $
inherit eutils
-IUSE="crypt"
-
DESCRIPTION="Internet based broadcasting system based on the mpeg3 streaming technology"
HOMEPAGE="http://www.icecast.org/"
SRC_URI="http://www.icecast.org/releases/${P}.tar.gz"
@@ -13,6 +11,7 @@ SRC_URI="http://www.icecast.org/releases/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 -ppc sparc"
+IUSE="crypt"
DEPEND="virtual/glibc"
@@ -20,6 +19,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-variables-gentoo.diff.bz2
+ epatch ${FILESDIR}/${PV}-errno.patch
}
src_compile() {