summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-11-05 19:30:29 +0000
committerMamoru Komachi <usata@gentoo.org>2003-11-05 19:30:29 +0000
commit376c6db14861c6349b012bfd560a0c3aa8a6e662 (patch)
treee4a4152ebadc9c1adf8c6d4bb41c60abf2dfdfa9 /net-www/dillo
parentUpdated I18N patch. Marked -r stable for x86 and alpha. (diff)
downloadhistorical-376c6db14861c6349b012bfd560a0c3aa8a6e662.tar.gz
historical-376c6db14861c6349b012bfd560a0c3aa8a6e662.tar.bz2
historical-376c6db14861c6349b012bfd560a0c3aa8a6e662.zip
Updated I18N patch. Marked -r stable for x86 and alpha.
Diffstat (limited to 'net-www/dillo')
-rw-r--r--net-www/dillo/Manifest6
-rw-r--r--net-www/dillo/dillo-0.7.3-r2.ebuild4
-rw-r--r--net-www/dillo/dillo-0.7.3-r3.ebuild116
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.3-r33
4 files changed, 124 insertions, 5 deletions
diff --git a/net-www/dillo/Manifest b/net-www/dillo/Manifest
index bd11a4bec826..d42a3e04b2a8 100644
--- a/net-www/dillo/Manifest
+++ b/net-www/dillo/Manifest
@@ -1,7 +1,7 @@
-MD5 18d622d42e3ab06728f2ced231cbe834 ChangeLog 3907
-MD5 22f08b9b6497a13860db95047c6091c9 dillo-0.7.3-r3.ebuild 3245
+MD5 6b09f0f9fab62f93830c6a0156e7a4c7 ChangeLog 4153
+MD5 280bc8419a93e5233130746bde95446c dillo-0.7.3-r3.ebuild 3244
MD5 6533dce06d5249db5b35b732e913f31d dillo-0.7.3-r1.ebuild 2596
-MD5 00205378c97847b2634370b9f9dd9ce5 dillo-0.7.3-r2.ebuild 3218
+MD5 2d3e3574fe7384111817233290438952 dillo-0.7.3-r2.ebuild 3217
MD5 5a68f4d28dc193393eee32ad8e9e70ea files/digest-dillo-0.7.3-r3 228
MD5 228c86b4db650b4d95d9ccbe853cecce files/digest-dillo-0.7.3-r1 142
MD5 4c339492b6d2cf3588cd8cd87482eeaa files/digest-dillo-0.7.3-r2 226
diff --git a/net-www/dillo/dillo-0.7.3-r2.ebuild b/net-www/dillo/dillo-0.7.3-r2.ebuild
index b088e653b8cf..e6b64b34e8b7 100644
--- a/net-www/dillo/dillo-0.7.3-r2.ebuild
+++ b/net-www/dillo/dillo-0.7.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r2.ebuild,v 1.2 2003/10/17 04:27:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r2.ebuild,v 1.3 2003/11/05 19:30:24 usata Exp $
inherit flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+KEYWORDS="x86 ~ppc ~sparc alpha ~mips ~hppa"
# Note that truetype, ssl and nls IUSE flags will take effect
# only if you enable cjk IUSE flag.
IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
diff --git a/net-www/dillo/dillo-0.7.3-r3.ebuild b/net-www/dillo/dillo-0.7.3-r3.ebuild
new file mode 100644
index 000000000000..10d33343bdd7
--- /dev/null
+++ b/net-www/dillo/dillo-0.7.3-r3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r3.ebuild,v 1.1 2003/11/05 19:30:24 usata Exp $
+
+inherit flag-o-matic
+
+S2=${WORKDIR}/dillo-gentoo-extras-patch3
+I18N_P=${P}-i18n-misc-20031105-2
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2
+ cjk? ( http://teki.jpn.ph/pc/software/${I18N_P}.diff.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+# Note that truetype, ssl and nls IUSE flags will take effect
+# only if you enable cjk IUSE flag.
+IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ../${I18N_P}.diff
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ einfo "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ einfo "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ einfo "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ einfo "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ einfo "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ else
+ einfo "Using default Dillo icon set"
+ fi
+}
+
+src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
+ local myconf
+
+ if [ -n "`use cjk`" ] ; then
+ if [ -n "`use truetype`" ] ; then
+ CPPFLAGS="${CPPFLAGS} -I/usr/include/freetype2"
+ LDFLAGS="${LDFLAGS} -L/usr/X11R6/lib -lXft"
+ export CPPFLAGS LDFLAGS
+ fi
+ myconf="`use_enable nls`
+ `use_enable ssl`
+ `use_enable truetype anti-alias`
+ --enable-meta-refresh
+ --enable-web-search"
+ fi
+
+ econf `use_enable ipv6` \
+ ${myconf} || die
+ emake || make || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/net-www/dillo/files/digest-dillo-0.7.3-r3 b/net-www/dillo/files/digest-dillo-0.7.3-r3
new file mode 100644
index 000000000000..064c2c2a6e75
--- /dev/null
+++ b/net-www/dillo/files/digest-dillo-0.7.3-r3
@@ -0,0 +1,3 @@
+MD5 896f4d8c752b86376bfb445740f01470 dillo-0.7.3.tar.bz2 345295
+MD5 3bc2370883e41905791f94f0b8e2f79b dillo-gentoo-extras-patch3.tar.bz2 86929
+MD5 005a44738e1a313605620db5b75deff8 dillo-0.7.3-i18n-misc-20031105-2.diff.bz2 246481