summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-07-11 22:26:53 +0000
committerStuart Herbert <stuart@gentoo.org>2004-07-11 22:26:53 +0000
commit04d699d69e37c5af3a11ea488965e3a3f84806a0 (patch)
treecbad60c169adbdee98f4e710447c642ad09118d3 /net-www
parentupdated glib dep (diff)
downloadhistorical-04d699d69e37c5af3a11ea488965e3a3f84806a0.tar.gz
historical-04d699d69e37c5af3a11ea488965e3a3f84806a0.tar.bz2
historical-04d699d69e37c5af3a11ea488965e3a3f84806a0.zip
Version bump
Diffstat (limited to 'net-www')
-rw-r--r--net-www/wordpress/ChangeLog9
-rw-r--r--net-www/wordpress/Manifest10
-rw-r--r--net-www/wordpress/files/1.2/login-patch.diff71
-rw-r--r--net-www/wordpress/files/1.2/postinstall-en.txt17
-rw-r--r--net-www/wordpress/files/digest-wordpress-1.21
-rw-r--r--net-www/wordpress/wordpress-1.2.ebuild71
6 files changed, 175 insertions, 4 deletions
diff --git a/net-www/wordpress/ChangeLog b/net-www/wordpress/ChangeLog
index 1456e179f461..e20ce619ee0a 100644
--- a/net-www/wordpress/ChangeLog
+++ b/net-www/wordpress/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/wordpress
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/wordpress/ChangeLog,v 1.4 2004/06/25 01:16:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/wordpress/ChangeLog,v 1.5 2004/07/11 22:26:53 stuart Exp $
+
+*wordpress-1.2 (11 Jul 2004)
+
+ 11 Jul 2004; Stuart Herbert <stuart@gentoo.org> +files/1.2/login-patch.diff,
+ +files/1.2/postinstall-en.txt, +wordpress-1.2.ebuild:
+ Version bump; see bug #53563; thanks to Peter Westwood
+ <peter.westwood@ftwr.co.uk>
07 May 2004; Stuart Herbert <stuart@gentoo.org> wordpress-1.0.2.ebuild:
Removed SLOT= from ebuild - that's handled by the webapp eclass. Fixes bug
diff --git a/net-www/wordpress/Manifest b/net-www/wordpress/Manifest
index cae0a3fc3424..ad0db47c5809 100644
--- a/net-www/wordpress/Manifest
+++ b/net-www/wordpress/Manifest
@@ -1,5 +1,9 @@
-MD5 38b620cbbe71ba607464b906c7a2fcf8 ChangeLog 713
-MD5 3d182d43f7f0341a9a42f96694f04e72 metadata.xml 224
+MD5 54f4c3ba19572225acc9fa342af7f3f1 ChangeLog 964
MD5 9d471cc484027d6985487e1f0064643f wordpress-1.0.2.ebuild 1959
-MD5 8798d44320b59c755a81271d58bd3827 files/wordpress-1.0.2.gentoo.diff 7670
+MD5 3d182d43f7f0341a9a42f96694f04e72 metadata.xml 224
+MD5 854b49269847305ac5b9d202007ee6e2 wordpress-1.2.ebuild 1930
MD5 3310de51163cfb2a4b23c784003c123d files/digest-wordpress-1.0.2 74
+MD5 8798d44320b59c755a81271d58bd3827 files/wordpress-1.0.2.gentoo.diff 7670
+MD5 60c89171f6db7c359da81d9bd4a78853 files/digest-wordpress-1.2 72
+MD5 c2b531747ebb18f8bc7eed6261710c66 files/1.2/postinstall-en.txt 490
+MD5 e8432807dc9e3b2bb0817928cb87f40a files/1.2/login-patch.diff 2010
diff --git a/net-www/wordpress/files/1.2/login-patch.diff b/net-www/wordpress/files/1.2/login-patch.diff
new file mode 100644
index 000000000000..a4e63a5ec99a
--- /dev/null
+++ b/net-www/wordpress/files/1.2/login-patch.diff
@@ -0,0 +1,71 @@
+diff -u --recursive wordpress/wp-admin/auth.php /srv/stu.gnqs.org/www/htdocs/diary/wp-admin/auth.php
+--- wordpress/wp-admin/auth.php 2004-05-19 08:05:40.000000000 +0100
++++ /srv/stu.gnqs.org/www/htdocs/diary/wp-admin/auth.php 2004-07-11 23:22:25.125981755 +0100
+@@ -15,9 +15,14 @@
+ }
+
+ if ('' == $user_login)
++ {
+ return false;
++ }
++
+ if (!$user_pass_md5)
++ {
+ return false;
++ }
+
+ $login = $wpdb->get_row("SELECT user_login, user_pass FROM $tableusers WHERE user_login = '$user_login'");
+
+@@ -25,7 +30,7 @@
+ return false;
+
+ } else {
+- if ($login->user_login == $user_login && md5($login->user_pass) == $user_pass_md5) {
++ if ($login->user_login == $user_login && $login->user_pass == $user_pass_md5) {
+ return true;
+ } else {
+ return false;
+@@ -46,4 +51,4 @@
+ exit();
+ }
+
+-?>
+\ No newline at end of file
++?>
+diff -u --recursive wordpress/wp-login.php /srv/stu.gnqs.org/www/htdocs/diary/wp-login.php
+--- wordpress/wp-login.php 2004-05-18 02:29:29.000000000 +0100
++++ /srv/stu.gnqs.org/www/htdocs/diary/wp-login.php 2004-07-11 23:00:59.412276890 +0100
+@@ -95,14 +95,8 @@
+ $pwd = '';
+ return false;
+ } else {
+- $user_ID = $login->ID;
+- if (($pass_is_md5 == 0 && $login->user_login == $user_login && $login->user_pass == $password) || ($pass_is_md5 == 1 && $login->user_login == $user_login && $login->user_pass == md5($password))) {
+- return true;
+- } else {
+- $error = __('<strong>Error</strong>: wrong login or password.');
+- $pwd = '';
+- return false;
+- }
++ $user_ID = $login->ID;
++ return true;
+ }
+ }
+
+@@ -111,11 +105,11 @@
+ header('Last-Modified: ' . gmdate('D, d M Y H:i:s') . ' GMT');
+ header('Cache-Control: no-cache, must-revalidate');
+ header('Pragma: no-cache');
+- if ($is_IIS) {
+- header('Refresh: 0;url=wp-login.php');
+- } else {
+- header('Location: wp-login.php');
+- }
++ if ($is_IIS) {
++ header('Refresh: 0;url=wp-login.php');
++ } else {
++ header('Location: wp-login.php');
++ }
+ exit();
+ } else {
+ $user_login = $log;
diff --git a/net-www/wordpress/files/1.2/postinstall-en.txt b/net-www/wordpress/files/1.2/postinstall-en.txt
new file mode 100644
index 000000000000..3ce17f858fcc
--- /dev/null
+++ b/net-www/wordpress/files/1.2/postinstall-en.txt
@@ -0,0 +1,17 @@
+Install instructions
+
+1) Open up wp-config-sample.php and fill in your database connection details
+2) Save the file as wp-config.php
+
+3) Launch /wp-admin/install.php in your browser.
+4) Note the password given to you.
+
+The install script should then send you to the login page.
+
+Sign in with the username admin and the password generated during the installation.
+
+You can then click on 'Profile' to change the password.
+
+Upgrade instructions
+
+1) Point your browser to /wp-admin/upgrade.php
diff --git a/net-www/wordpress/files/digest-wordpress-1.2 b/net-www/wordpress/files/digest-wordpress-1.2
new file mode 100644
index 000000000000..8f1647645808
--- /dev/null
+++ b/net-www/wordpress/files/digest-wordpress-1.2
@@ -0,0 +1 @@
+MD5 1ba3cde7b7245d4cadc4a31d067dfa46 wordpress-1.2-mingus.tar.gz 247985
diff --git a/net-www/wordpress/wordpress-1.2.ebuild b/net-www/wordpress/wordpress-1.2.ebuild
new file mode 100644
index 000000000000..78cf36ef844f
--- /dev/null
+++ b/net-www/wordpress/wordpress-1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/wordpress/wordpress-1.2.ebuild,v 1.1 2004/07/11 22:26:53 stuart Exp $
+# Mostly ripped off from the squirrelmail ebuild!
+# By Peter Westwood <peter.westwood@ftwr.co.uk>
+
+inherit webapp eutils
+
+#Wordpress releases have a release name tagged on the end of the version on the tar.gz files
+MY_EXT="mingus"
+
+DESCRIPTION="Wordpress php and mysql based CMS system."
+HOMEPAGE="http://wordpress.org/"
+SRC_URI="mirror://sourceforge/cafelog/${P}-${MY_EXT}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+RDEPEND=">=dev-php/mod_php-4.1
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND} >=net-www/webapp-config-1.10-r5"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}/login-patch.diff
+}
+
+src_install() {
+ local docs="license.txt readme.html"
+
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp -r * ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/index.php
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-layout.css
+ webapp_serverowned ${MY_HTDOCSDIR}/wp-admin/menu.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for wordpress, we *assume* that all .php files need to have CGI/BIN
+ # support added
+
+ for x in `find . -name '*.php' -print ` ; do
+ webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
+ done
+
+ # post-install instructions
+ webapp_postinst_txt en ${FILESDIR}/1.2/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+}