summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-08 21:05:51 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-08 21:05:51 +0000
commit602d7766303eb27cffe20a4a9f6e8a651b3f85ce (patch)
treed2a7aa80eafac25e50c8d1aa982c95cdb57ffa3b /net-www
parentversion bump, close bug #56422. (diff)
downloadhistorical-602d7766303eb27cffe20a4a9f6e8a651b3f85ce.tar.gz
historical-602d7766303eb27cffe20a4a9f6e8a651b3f85ce.tar.bz2
historical-602d7766303eb27cffe20a4a9f6e8a651b3f85ce.zip
7.52 static only on amd64.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/opera/ChangeLog5
-rw-r--r--net-www/opera/Manifest10
-rw-r--r--net-www/opera/opera-7.52.ebuild24
3 files changed, 24 insertions, 15 deletions
diff --git a/net-www/opera/ChangeLog b/net-www/opera/ChangeLog
index fcb99e061e29..a6c5adf716a1 100644
--- a/net-www/opera/ChangeLog
+++ b/net-www/opera/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/opera
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/opera/ChangeLog,v 1.72 2004/07/08 13:14:45 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera/ChangeLog,v 1.73 2004/07/08 21:05:51 eradicator Exp $
+
+ 08 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> opera-7.52.ebuild:
+ amd64 static only
08 Jul 2004; Heinrich Wendel <lanius@gentoo.org> opera-7.51-r1.ebuild,
opera-7.51.ebuild:
diff --git a/net-www/opera/Manifest b/net-www/opera/Manifest
index d397cdc7ac0c..b55a5fc536b4 100644
--- a/net-www/opera/Manifest
+++ b/net-www/opera/Manifest
@@ -1,11 +1,11 @@
+MD5 72e148f116d0a602c3a804dfb133e924 ChangeLog 12076
+MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
MD5 6bc54e68ebc4efff54d13094f092b6d5 opera-6.12.ebuild 3304
-MD5 e93cd13de35750b1910cf2039f473abc opera-7.52.ebuild 4551
-MD5 85383966c3542de9c8fb14f62be9b1b1 opera-7.23-r1.ebuild 3842
MD5 e98a0549d46aadd78a43ba042539b497 opera-7.11-r2.ebuild 3670
-MD5 013ccd017a0f48cd74914f8647924a8c ChangeLog 11979
-MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
+MD5 85383966c3542de9c8fb14f62be9b1b1 opera-7.23-r1.ebuild 3842
+MD5 92430dea580a65ba41ca7c50c736884d opera-7.52.ebuild 4880
MD5 cbaaedfc5f57eea800b4a64928d77683 files/digest-opera-6.12 89
-MD5 138740c5a86406ca1ddce49765b4132a files/digest-opera-7.52 464
MD5 fd6b6eba741abd18ba590e9a5c0f225f files/digest-opera-7.11-r2 177
MD5 9a8a982857424445242430340a70783c files/digest-opera-7.23-r1 558
MD5 8336a92d029cd448620bf4bbd4c55715 files/opera.desktop 135
+MD5 138740c5a86406ca1ddce49765b4132a files/digest-opera-7.52 464
diff --git a/net-www/opera/opera-7.52.ebuild b/net-www/opera/opera-7.52.ebuild
index 51045d175460..39de6cc4d0b2 100644
--- a/net-www/opera/opera-7.52.ebuild
+++ b/net-www/opera/opera-7.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/opera/opera-7.52.ebuild,v 1.2 2004/07/07 17:10:09 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/opera/opera-7.52.ebuild,v 1.3 2004/07/08 21:05:51 eradicator Exp $
IUSE="static spell"
@@ -16,12 +16,15 @@ HOMEPAGE="http://www.opera.com/linux/"
SRC_URI="
x86? ( static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 ) )
x86? ( !static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-en.tar.bz2 ) )
- amd64? ( static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 ) )
- amd64? ( !static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-en.tar.bz2 ) )
+ amd64? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 )
ppc? ( static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/ppc/static/${PN}-${OPERAVER}.1-static-qt.ppc-en.tar.bz2 ) )
ppc? ( !static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/ppc/shared/gcc-2.95/${PN}-${OPERAVER}.2-shared-qt.ppc-en.tar.bz2 ) )
sparc? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/sparc/static/${PN}-${OPERAVER}.1-static-qt.sparc-en.tar.bz2 )"
+# amd64 shared libs require app-emulation/emul-linux-x86-qtlibs-1 which is not stable yet
+# amd64? ( static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/static/${PN}-${OPERAVER}.1-static-qt.i386-en.tar.bz2 ) )
+# amd64? ( !static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-en.tar.bz2 ) )
+
# sparc shared version does not work for me as it uses gcc-2.95 - eradicator
# sparc? ( static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/sparc/static/${PN}-${OPERAVER}.1-static-qt.sparc-en.tar.bz2 ) )
# sparc? ( !static? ( ftp://ftp.opera.com/pub/opera/linux/${OPERAFTPDIR}/final/en/sparc/shared/gcc-2.95/${PN}-${OPERAVER}.2-shared-qt.sparc-en.tar.bz2 ) )"
@@ -35,12 +38,15 @@ RDEPEND="virtual/x11
>=media-libs/fontconfig-2.1.94-r1
media-libs/libexif
x11-libs/openmotif
- static? (
- amd64? ( app-emulation/emul-linux-x86-xlibs ) )
- !static? (
- amd64? ( =app-emulation/emul-linux-x86-qtlibs-1* )
- !amd64? ( =x11-libs/qt-3* ) )
- spell? ( app-text/aspell )"
+ spell? ( app-text/aspell )
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ !amd64 ( !sparc? ( !static? ( =x11-libs/qt-3* ) ) )"
+
+# static? (
+# amd64? ( app-emulation/emul-linux-x86-xlibs ) )
+# !static? (
+# amd64? ( =app-emulation/emul-linux-x86-qtlibs-1* )
+# !amd64? ( =x11-libs/qt-3* ) )
SLOT="0"
LICENSE="OPERA"