summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-07 17:22:06 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-07 17:22:06 +0000
commit88f6a671a2e3354d250cb359be4cd8e82b88e526 (patch)
tree632544f6387ef1cc5bf19e15182a09ad9fa04161 /x11-plugins
parentdev-lisp/cl-cxml removal, p.masked from 17Sep2010, wrt bug #337963 (diff)
downloadhistorical-88f6a671a2e3354d250cb359be4cd8e82b88e526.tar.gz
historical-88f6a671a2e3354d250cb359be4cd8e82b88e526.tar.bz2
historical-88f6a671a2e3354d250cb359be4cd8e82b88e526.zip
Initial import
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-led-notification/ChangeLog11
-rw-r--r--x11-plugins/pidgin-led-notification/Manifest5
-rw-r--r--x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch34
-rw-r--r--x11-plugins/pidgin-led-notification/metadata.xml10
-rw-r--r--x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild43
5 files changed, 103 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-led-notification/ChangeLog b/x11-plugins/pidgin-led-notification/ChangeLog
new file mode 100644
index 000000000000..f05859696ae4
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/pidgin-led-notification
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-led-notification/ChangeLog,v 1.1 2010/11/07 17:22:06 xmw Exp $
+
+*pidgin-led-notification-0.1 (07 Nov 2010)
+
+ 07 Nov 2010; Michael Weber <xmw@gentoo.org>
+ +pidgin-led-notification-0.1.ebuild,
+ +files/pidgin-led-notification-0.1-hardware.patch, +metadata.xml:
+ Initial import with patch to support more led hardware
+
diff --git a/x11-plugins/pidgin-led-notification/Manifest b/x11-plugins/pidgin-led-notification/Manifest
new file mode 100644
index 000000000000..c396f08d7944
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/Manifest
@@ -0,0 +1,5 @@
+AUX pidgin-led-notification-0.1-hardware.patch 1217 RMD160 3cec32d7b666c0ad48169492bb91449d307a84b5 SHA1 08037791ef7fb008a74e5e57ed3118a778531483 SHA256 84d3eaf36a26a08b730e2ea382711d704de21298278fcd42e7af3a4403339f62
+DIST led-notification-0.1.tar.bz2 8848 RMD160 ca144643519c9d855d06cd042b2bf217214d8f7f SHA1 e63f9df78705aee1a2edd8dfa0f2a3646ac61ce9 SHA256 aed13cd45e6bbb89574d9eafe477adc7ef3f0a1768cb1f3c5f573e08186e1a16
+EBUILD pidgin-led-notification-0.1.ebuild 1102 RMD160 fb8e15d6515c7a188f348ff381ed0a77963f957a SHA1 a60771f5a05ce9303d5b5e9fd6e19bd286c2412e SHA256 196de295b0c8faf0e699efdfb58e9d38623e3e56de6d1ae46bf70036fddb9a0f
+MISC ChangeLog 495 RMD160 d2c7854c7269b28e4eee356d1907f7c371d59c1c SHA1 42d5c72ae00ec0719b13ad33b5a6bfcf892dffdb SHA256 ccbd0c905b2d62b367abf2552bbd9fb24335aeb756f7b6893a5c705090a75a24
+MISC metadata.xml 245 RMD160 6b03982a4d5f32d9fa6b9259ae36f9fcb07c8404 SHA1 fb16c7b4c5ab071dd979f761b8bb075f5396b737 SHA256 375a1da02cd2c393ce2378a73c1ce08134bc030b3bb378c6a4d6ca9cd5be1f8d
diff --git a/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
new file mode 100644
index 000000000000..aaabada116db
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
@@ -0,0 +1,34 @@
+--- led-notification-0.1/led-notification.c
++++ led-notification-0.1/led-notification.c
+@@ -54,9 +54,9 @@
+ }
+
+ if(state) {
+- fputs("1", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_on"), file);
+ } else {
+- fputs("0", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_off"), file);
+ }
+
+ fclose(file);
+@@ -155,6 +155,10 @@
+
+ ent=pidgin_prefs_labeled_entry(vbox2,"File to control led:",
+ "/plugins/gtk/gtk-simom-lednot/filename",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led on:",
++ "/plugins/gtk/gtk-simom-lednot/led_on",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led off:",
++ "/plugins/gtk/gtk-simom-lednot/led_off",sg);
+
+ gtk_widget_show_all(frame);
+ return frame;
+@@ -166,6 +170,8 @@
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/chat", "nick");
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/filename",
+ "/proc/acpi/asus/mled");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_on", "1");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_off", "0");
+ }
+
+ static gboolean plugin_load(PurplePlugin *plugin) {
diff --git a/x11-plugins/pidgin-led-notification/metadata.xml b/x11-plugins/pidgin-led-notification/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
new file mode 100644
index 000000000000..fc14238f4947
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild,v 1.1 2010/11/07 17:22:06 xmw Exp $
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Pidgin plugin to notify by writining '1's and '0's to (led) control files"
+HOMEPAGE="http://sites.google.com/site/simohmattila/led-notification"
+MY_PN=${PN/pidgin-/}
+MY_P=${MY_PN}-${PV}
+SRC_URI="http://sites.google.com/site/simohmattila/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hardware.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} -fpic $(pkg-config --cflags gtk+-2.0 pidgin) \
+ -shared ${MY_PN}.c -o ${MY_PN}.so \
+ ${LDFLAGS} $(pkg-config --libs gtk+-2.0 pidgin) || die
+}
+
+src_install() {
+ insinto ${EPREFIX}/usr/$(get_libdir)/pidgin
+ insopts -m755
+ doins ${MY_PN}.so || die
+ dodoc README || die
+}