summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-04 15:19:41 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-04 15:19:41 +0000
commitaa067b4e22ba0171f18fdb104ec7894ca7b69805 (patch)
tree6af3d96a7c3575e36cbcdd43cc9ed1cc671c6a99 /x11-wm/sawfish/sawfish-1.0.1-r5.ebuild
parentBumped to new version. (diff)
downloadhistorical-aa067b4e22ba0171f18fdb104ec7894ca7b69805.tar.gz
historical-aa067b4e22ba0171f18fdb104ec7894ca7b69805.tar.bz2
historical-aa067b4e22ba0171f18fdb104ec7894ca7b69805.zip
Corrected the rep-gtk dep to match with the correct gnome1 version. Also should fix bug #4728
Diffstat (limited to 'x11-wm/sawfish/sawfish-1.0.1-r5.ebuild')
-rw-r--r--x11-wm/sawfish/sawfish-1.0.1-r5.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild b/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild
new file mode 100644
index 000000000000..7f17665fd870
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild,v 1.1 2002/08/04 15:19:41 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="mirror://sourceforge/sawmill/${P}.tar.gz"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/rep-gtk-0.15*
+ >=dev-libs/librep-0.14
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+RDEPEND="${DEPEND}
+ =x11-libs/gtk+-1*
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 <${FILESDIR}/capplet-crash.patch || die
+ #fix buggy Makefile with newer libtool
+ patch -p0 <${FILESDIR}/sawfish-${PV}-exec.patch || die
+
+ #update libtool for "relink" bug fix
+ libtoolize --copy --force
+ aclocal
+}
+
+src_compile() {
+
+ local myconf
+
+ use esd \
+ && myconf="--with-esd" \
+ || myconf="--without-esd"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet" \
+ || myconf="${myconf} --disable-gnome-widgets --disable-capplet"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ use gtk || use gnome \
+ && myconf="${myconf} --with-gdk-pixbuf" \
+ || myconf="${myconf} --without-gdk-pixbuf"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die
+
+ use nls || rmdir ${D}/usr/share/locale
+
+ dodoc AUTHORS BUGS COPYING ChangeLog
+ dodoc DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+ fi
+}