summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.0.1-r51
-rw-r--r--x11-wm/sawfish/sawfish-1.0.1-r5.ebuild84
3 files changed, 91 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 142247410c34..4522c4cfb0b7 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.11 2002/06/24 01:58:43 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.12 2002/08/04 15:19:41 stroke Exp $
+*sawfish-1.0.1-r5 (4 Aug 2002)
+ 4 Aug 2002; Gabriele Giorgetti <stroke@gentoo.org> sawfish-1.0.1-r5.ebuild:
+ Corrected the rep-gtk dep to match with the correct gnome1 version.
+ Also should fix bug #4728
+
*sawfish-2.0 (24 Jun 2002)
24 Jun 2002; Martin Schlemmer <azarah@gentoo.org> :
Version update. Finally figured out why it moans about the ${S}/src/.libs
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.0.1-r5 b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r5
new file mode 100644
index 000000000000..3592e2b26ab4
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r5
@@ -0,0 +1 @@
+MD5 b1587ea76cca08ec951f2536c17a307e sawfish-1.0.1.tar.gz 1326727
diff --git a/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild b/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild
new file mode 100644
index 000000000000..7f17665fd870
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.1-r5.ebuild,v 1.1 2002/08/04 15:19:41 stroke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="mirror://sourceforge/sawmill/${P}.tar.gz"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/rep-gtk-0.15*
+ >=dev-libs/librep-0.14
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+RDEPEND="${DEPEND}
+ =x11-libs/gtk+-1*
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 <${FILESDIR}/capplet-crash.patch || die
+ #fix buggy Makefile with newer libtool
+ patch -p0 <${FILESDIR}/sawfish-${PV}-exec.patch || die
+
+ #update libtool for "relink" bug fix
+ libtoolize --copy --force
+ aclocal
+}
+
+src_compile() {
+
+ local myconf
+
+ use esd \
+ && myconf="--with-esd" \
+ || myconf="--without-esd"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet" \
+ || myconf="${myconf} --disable-gnome-widgets --disable-capplet"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ use gtk || use gnome \
+ && myconf="${myconf} --with-gdk-pixbuf" \
+ || myconf="${myconf} --without-gdk-pixbuf"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die
+
+ use nls || rmdir ${D}/usr/share/locale
+
+ dodoc AUTHORS BUGS COPYING ChangeLog
+ dodoc DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+ fi
+}