summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog5
-rw-r--r--app-emulation/qemu/Manifest4
-rw-r--r--app-emulation/qemu/qemu-0.7.0.ebuild15
3 files changed, 17 insertions, 7 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 3fb3d137622a..905c7b6fb59e 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.32 2005/05/07 09:23:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.33 2005/05/12 09:13:55 lu_zero Exp $
+
+ 12 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
+ Hardened updates from Kevin F. Quinn <co@kevquinn.com>
07 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
Some fixes here and there, thanks to Sok Ann Yap <sokann@gmail.com>
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 26e6253db58c..030f8455717b 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,9 +1,9 @@
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 518988ab13f6b610696b8706d31d2fb9 qemu-0.6.0.ebuild 1895
-MD5 1ea07614417ecc844a61e3508b265d2b qemu-0.7.0.ebuild 3891
+MD5 4b003235f5518371fb812a0c6ed162de qemu-0.7.0.ebuild 4086
MD5 b035e8de3718e77cc27918198bf49fb6 qemu-0.6.1-r1.ebuild 2143
MD5 e65dab4abb0028ab15d60ecd60ca4ba9 qemu-0.6.1.ebuild 2071
-MD5 1c82bce2bfc1d4b3b1a9fc3f1a747aa8 ChangeLog 4131
+MD5 4360bbaa2a8b8af7ad56cc3042953cf5 ChangeLog 4257
MD5 1f8638d68cffbd8b96df97dcb0868b88 files/digest-qemu-0.6.1-r1 63
MD5 ede1278e0122a8439c156bd1380a37d5 files/qemu_gcc34.patch.gz 406
MD5 0b85ac42eaa41830ac9b4eccf4a118bd files/qemu-0.6.0-sigaction.patch 677
diff --git a/app-emulation/qemu/qemu-0.7.0.ebuild b/app-emulation/qemu/qemu-0.7.0.ebuild
index 44f7f5f5ad60..d8ea3e316db7 100644
--- a/app-emulation/qemu/qemu-0.7.0.ebuild
+++ b/app-emulation/qemu/qemu-0.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.5 2005/05/07 09:23:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.6 2005/05/12 09:13:55 lu_zero Exp $
-inherit eutils flag-o-matic linux-mod
+inherit eutils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
@@ -34,6 +34,9 @@ set_target_list() {
}
pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
# ( use kqemu || use qvm86 ) && linux-mod_pkg_setup
use kqemu && linux-mod_pkg_setup
}
@@ -60,7 +63,8 @@ src_unpack() {
# fi
cd ${S}
# Alter target makefiles to accept CFLAGS set via flag-o.
- sed -i 's/^CFLAGS=-Wall -O2 -g/CFLAGS+=-Wall/' Makefile Makefile.target
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
# Ensure mprotect restrictions are relaxed for emulator binaries
[[ -x /sbin/paxctl ]] && \
sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
@@ -70,9 +74,12 @@ src_unpack() {
}
src_compile() {
- #Let the application set it's cflags
+ #Let the application set its cflags
unset CFLAGS
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
myconf=""
set_target_list
# --interp-prefix=${RUNTIME_PATH}/qemu-%M