summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/IceE/IceE-1.3.0.ebuild')
-rw-r--r--dev-cpp/IceE/IceE-1.3.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-cpp/IceE/IceE-1.3.0.ebuild b/dev-cpp/IceE/IceE-1.3.0.ebuild
new file mode 100644
index 000000000000..bd2549058380
--- /dev/null
+++ b/dev-cpp/IceE/IceE-1.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/IceE/IceE-1.3.0.ebuild,v 1.1 2009/01/13 12:28:56 b33fc0d3 Exp ${P}.ebuild,v 1.1 2009/01/07 15:24:59 b33fc0d3 Exp $
+
+inherit eutils mono multilib toolchain-funcs
+
+DESCRIPTION="The Internet Communications Engine (Ice) is a modern object-oriented middleware with support for C++, .NET, Java, Python, Ruby, and PHP"
+HOMEPAGE="http://www.zeroc.com/icee/index.html"
+SRC_URI="http://www.zeroc.com/download/IceE/${PV/\.0//}/IceE-${PV}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~x86"
+IUSE="mono"
+
+DEPEND=">=sys-libs/db-4.6.21
+ >=dev-libs/expat-1.95.7
+ >=app-arch/bzip2-1.0.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/IceE-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch "${FILESDIR}/${P}-makefile-2.patch"
+ epatch "${FILESDIR}/${P}-gcc4.3-fix.patch"
+ epatch "${FILESDIR}/${P}-maverick-fix.patch"
+
+}
+
+src_compile() {
+ if tc-is-cross-compiler ; then
+ export CXX="${CHOST}-g++"
+ export AR="${CHOST}-ar"
+ fi
+
+ sed -i "s/DESTDIR_PLACE_HOLDER/${D//\//\\/}\/usr/" cppe/config/Make.rules
+
+ emake configure || 'emake configure failed'
+ emake || die 'emake failed'
+}
+
+src_install() {
+ dodir /usr/share/${PN}
+
+ emake install || die 'emake install failed'
+
+ cd "${D}"/usr
+ rm -rf LICENSE ICEE_LICENSE
+ tc-is-cross-compiler && rm bin/slice2cppe
+
+ mv "${D}"/usr/slice "${D}"/usr/share/${PN}
+}