summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-selinux/python-selinux-2.16.ebuild')
-rw-r--r--dev-python/python-selinux/python-selinux-2.16.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/python-selinux/python-selinux-2.16.ebuild b/dev-python/python-selinux/python-selinux-2.16.ebuild
index de85fa3ca7c9..23f156766f97 100644
--- a/dev-python/python-selinux/python-selinux-2.16.ebuild
+++ b/dev-python/python-selinux/python-selinux-2.16.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.3 2006/01/14 01:00:11 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16.ebuild,v 1.4 2006/02/09 00:20:48 pebenito Exp $
inherit python
-python_version
DESCRIPTION="Python bindings for SELinux functions"
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
LICENSE="GPL-2"
SLOT="0"
+SRC_URI="${P}.c.bz2"
KEYWORDS="~alpha amd64 mips ppc sparc x86"
#KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~mips"
@@ -21,16 +21,18 @@ S=${WORKDIR}/${PN}
src_unpack() {
mkdir -p ${S}
- bzcat ${FILESDIR}/${P}.c.bz2 > ${S}/selinux.c || die
+ bzcat ${DISTDIR}/${A} > ${S}/selinux.c || die
}
src_compile() {
cd ${S}
+ python_version
einfo "Compiling selinux.so for python ${PYVER}"
gcc -fPIC -shared -o selinux.so -I /usr/include/python${PYVER}/ selinux.c -lselinux || die
}
src_install() {
+ python_version
insinto /usr/lib/python${PYVER}/site-packages
doins selinux.so
}