summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/ChangeLog7
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-5.4.7-r11
-rw-r--r--media-gfx/imagemagick/imagemagick-5.4.7-r1.ebuild86
3 files changed, 93 insertions, 1 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index 7e340926a558..04746b41dfe9 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.16 2002/09/15 15:31:40 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.17 2002/09/16 01:22:31 mcummings Exp $
+
+*imagemagick-5.4.7-r1 (15 Sep 2002)
+ 15 Sep 2002; <mcummings@gentoo.org> : version bump is at Grant's suggestion
+ since the last version would install, this makes sure anyone that installed
+ it gets the working copy.
*imagemagick-5.4.7 (08 Jul 2002)
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-5.4.7-r1 b/media-gfx/imagemagick/files/digest-imagemagick-5.4.7-r1
new file mode 100644
index 000000000000..693df6a4434d
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-5.4.7-r1
@@ -0,0 +1 @@
+MD5 2059a2dad90a797cd6bb26734b37bb45 ImageMagick-5.4.7-1.tar.bz2 2897178
diff --git a/media-gfx/imagemagick/imagemagick-5.4.7-r1.ebuild b/media-gfx/imagemagick/imagemagick-5.4.7-r1.ebuild
new file mode 100644
index 000000000000..de3165383b9c
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-5.4.7-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-5.4.7-r1.ebuild,v 1.1 2002/09/16 01:22:32 mcummings Exp $
+
+inherit libtool
+inherit perl-module
+
+MY_PN=ImageMagick
+MY_P=${MY_PN}-${PV}-1
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+SRC_URI="http://imagemagick.sourceforge.net/http/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.imagemagick.org/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc"
+
+DEPEND="media-libs/libpng
+
+ >=sys-apps/bzip2-1
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/freetype-2.0
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ X? ( virtual/x11
+ >=app-text/dgs-0.5.9.1 )
+ cups? ( >=app-text/ghostscript-6.50 )
+ lcms? ( >=media-libs/lcms-1.06 )
+ perl? ( >=sys-devel/perl-5 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )"
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use perl || myconf="--without-perl"
+ use lcms || myconf="${myconf} --without-lcms"
+ use xml2 || myconf="${myconf} --without-xml"
+ use X || myconf="${myconf} --with-x=no"
+
+ # Netscape is still used ? More people should have Mozilla
+ cp configure configure.orig
+ sed -e 's:netscape:mozilla:g' configure.orig > configure
+
+ econf \
+ --enable-shared \
+ --enable-static \
+ --enable-lzw \
+ --with-ttf \
+ --without-fpx \
+ --without-gslib \
+ --without-hdf \
+ --without-jbig \
+ --without-wmf \
+ --with-threads \
+ --without-perl \
+ ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+
+ cd ${S}/PerlMagick
+ make clean
+ perl-module_src_prep
+ cd ${S}
+}
+
+src_install() {
+
+ myinst="prefix=${D}/usr PREFIX=${D}/usr"
+ myinst="${myinst} MagickSharePath=${D}/usr/share/ImageMagick/"
+ myinst="${myinst} pkgdocdir=${D}/usr/share/doc/${PF}/html"
+ myinst="${myinst} mandir=${D}/usr/share/man"
+ myinst="${myinst} datadir=${D}/usr/share"
+
+ mydoc="*.txt"
+
+ cd ${S}
+ make ${myinst} install || die
+ cd ${S}
+ cd ${S}/PerlMagick
+ perl-module_src_install
+
+ rm -f ${D}/usr/share/ImageMagick/*.txt
+
+}