summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.5.11.ebuild57
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild6
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_beta10.ebuild74
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild6
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild7
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.5.111
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_beta101
7 files changed, 16 insertions, 136 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild b/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild
deleted file mode 100644
index 4b0ee139f68d..000000000000
--- a/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.11.ebuild,v 1.6 2002/07/11 06:30:40 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Advanced Linux Sound Architecture modules"
-SRC_URI="ftp://ftp.alsa-project.org/pub/driver/alsa-driver-${PV}.tar.bz2"
-HOMEPAGE="http://www.alsa-project.org"
-
-#virtual/glibc should depend on specific kernel headers
-DEPEND="sys-devel/autoconf virtual/glibc"
-PROVIDE="virtual/alsa"
-KV=""
-
-pkg_setup() {
- KV=`readlink /usr/src/linux`
- if [ $? -ne 0 ] ; then
- echo
- echo "/usr/src/linux symlink does not exist; cannot continue."
- echo
- die
- else
- #alsa-driver will compile modules for the kernel pointed to by /usr/src/linux
- KV=${KV/linux-/}
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp configure.in configure.in.orig
- sed -e 's/-m.86//g' configure.in.orig > configure.in
- autoconf
-}
-
-src_compile() {
- try ./configure --with-kernel="${ROOT}usr/src/linux-${KV}" --with-isapnp=yes --with-sequencer=yes --with-oss=yes --with-cards=all
- try emake
-}
-
-src_install () {
- #point this to the kernel headers in the future, not the kernel sources
- insinto /usr/include/linux
- cd ${S}/include
- doins asound.h asoundid.h asequencer.h ainstr_*.h
- dodoc INSTALL FAQ
- dodir /lib/modules/${KV}/misc
- cp ${S}/modules/*.o ${D}/lib/modules/${KV}/misc
- dodir /etc/modutils
- insinto /etc/modutils
- doins ${FILESDIR}/alsa
- #this is the new modular modules system (from Debian) :)
-}
-
-pkg_postinst() {
- /usr/sbin/update-modules || return 0
-}
diff --git a/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild b/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild
index 6114424b56fa..f7e1586342ae 100644
--- a/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild,v 1.5 2002/07/11 06:30:40 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild,v 1.6 2002/07/16 11:36:53 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Advanced Linux Sound Architecture modules"
@@ -11,6 +11,10 @@ HOMEPAGE="http://www.alsa-project.org"
DEPEND="sys-devel/autoconf virtual/glibc"
PROVIDE="virtual/alsa"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
setkv() {
KV=""
KV=`readlink /usr/src/linux`
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_beta10.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_beta10.ebuild
deleted file mode 100644
index cc414e1c9685..000000000000
--- a/media-sound/alsa-driver/alsa-driver-0.9.0_beta10.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_beta10.ebuild,v 1.4 2002/07/11 06:30:40 drobbins Exp $
-
-# By default, drivers for all supported cards will be compiled.
-# If you want to only compile for specific card(s), set ALSA_CARDS
-# environment variable accordingly
-[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
-
-#transform P to match tarball versioning
-MYPV=${PV/_beta/beta}
-MYP="${PN}-${MYPV}"
-KV=""
-
-S=${WORKDIR}/${MYP}
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-
-SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${MYP}.tar.bz2"
-
-HOMEPAGE="http://www.alsa-project.org"
-
-#virtual/glibc should depend on specific kernel headers
-DEPEND="sys-devel/autoconf virtual/glibc"
-PROVIDE="virtual/alsa"
-
-pkg_setup() {
- KV=`readlink /usr/src/linux`
- if [ $? -ne 0 ] ; then
- echo
- echo "/usr/src/linux symlink does not exist; cannot continue."
- echo
- die
- else
- #alsa-driver will compile modules for the kernel pointed to by /usr/src/linux
- KV=${KV/linux-/}
- fi
-}
-
-src_compile() {
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --with-kernel="${ROOT}usr/src/linux-${KV}" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-oss=yes \
- --with-cards=${ALSA_CARDS} \
- || die "./configure failed"
-
- emake || die "Parallel Make Failed"
-
-}
-
-src_install () {
-
- insinto /usr/include/sound
- cd ${S}/include
- doins *.h
- cd ${S}
- dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO
- dodir /lib/modules/${KV}/misc
- cp ${S}/modules/*.o ${D}/lib/modules/${KV}/misc
- insinto /etc/modules.d
- doins ${FILESDIR}/alsa
- insinto /etc/init.d
- doins ${S}/utils/alsasound
-
-}
-
-pkg_postinst () {
- /usr/sbin/update-modules || return 0
-}
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
index bf0d4e6eb0b6..315f6e6adf74 100644
--- a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild,v 1.3 2002/07/11 06:30:40 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild,v 1.4 2002/07/16 11:36:53 seemant Exp $
DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
HOMEPAGE="http://www.alsa-project.org/"
@@ -21,6 +21,10 @@ DEPEND="sys-devel/autoconf
RDEPEND="${DEPEND}"
PROVIDE="virtual/alsa"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86"
+
src_unpack() {
# Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
# instead of /etc/init.d. However, this causes alsa's installer
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild
index 80fcf1dbc109..c0f4d095d563 100644
--- a/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild,v 1.3 2002/07/12 04:44:53 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc2.ebuild,v 1.4 2002/07/16 11:36:53 seemant Exp $
DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
HOMEPAGE="http://www.alsa-project.org/"
@@ -21,6 +21,11 @@ DEPEND="sys-devel/autoconf
RDEPEND="${DEPEND}"
PROVIDE="virtual/alsa"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 ppc"
+
src_unpack() {
# Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
# instead of /etc/init.d. However, this causes alsa's installer
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11 b/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11
deleted file mode 100644
index 0c5833cd7782..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-0.5.11
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ff807499928379c4274a307855b9eeeb alsa-driver-0.5.11.tar.bz2 904757
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_beta10 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_beta10
deleted file mode 100644
index a4bec47d1748..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_beta10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d3e9fde5c551a19652c07da54f878379 alsa-driver-0.9.0beta10.tar.bz2 1039578