summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/kdenlive/files/kdenlive-0.7-avcodeclink.patch')
-rw-r--r--media-video/kdenlive/files/kdenlive-0.7-avcodeclink.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-video/kdenlive/files/kdenlive-0.7-avcodeclink.patch b/media-video/kdenlive/files/kdenlive-0.7-avcodeclink.patch
new file mode 100644
index 000000000000..508966102190
--- /dev/null
+++ b/media-video/kdenlive/files/kdenlive-0.7-avcodeclink.patch
@@ -0,0 +1,30 @@
+Index: kdenlive-0.7/cmake/modules/FindLIBFFMPEG.cmake
+===================================================================
+--- kdenlive-0.7.orig/cmake/modules/FindLIBFFMPEG.cmake
++++ kdenlive-0.7/cmake/modules/FindLIBFFMPEG.cmake
+@@ -33,6 +33,13 @@ FIND_LIBRARY(LIBFFMPEG_LIBRARY
+ NO_DEFAULT_PATH
+ )
+
++FIND_LIBRARY(LIBAVCODEC_LIBRARY
++ NAMES avcodec
++ PATHS ${FFMPEG_LIBS_PATH}
++ /usr/lib /usr/local/lib
++ NO_DEFAULT_PATH
++)
++
+ IF (LIBFFMPEG_LIBRARY)
+ MESSAGE(STATUS "Found FFmpeg Libavformat library: ${LIBFFMPEG_LIBRARY}")
+ ELSE (LIBFFMPEG_LIBRARY)
+Index: kdenlive-0.7/src/CMakeLists.txt
+===================================================================
+--- kdenlive-0.7.orig/src/CMakeLists.txt
++++ kdenlive-0.7/src/CMakeLists.txt
+@@ -17,6 +17,7 @@ LINK_LIBRARIES(
+ ${LIBMLT_LIBRARY}
+ ${LIBMLTPLUS_LIBRARY}
+ ${LIBFFMPEG_LIBRARY}
++${LIBAVCODEC_LIBRARY}
+ ${NEPOMUK_LIBRARIES}
+ )
+