summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/squidguard/files/squidguard-1.4-autoheader.patch')
-rw-r--r--net-proxy/squidguard/files/squidguard-1.4-autoheader.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-proxy/squidguard/files/squidguard-1.4-autoheader.patch b/net-proxy/squidguard/files/squidguard-1.4-autoheader.patch
new file mode 100644
index 000000000000..af97d8e9a5ca
--- /dev/null
+++ b/net-proxy/squidguard/files/squidguard-1.4-autoheader.patch
@@ -0,0 +1,61 @@
+diff -Nru squidGuard-1.4.orig/configure.in squidGuard-1.4/configure.in
+--- squidGuard-1.4.orig/configure.in 2009-01-03 20:04:30.000000000 +0000
++++ squidGuard-1.4/configure.in 2009-01-10 13:08:49.000000000 +0000
+@@ -93,18 +93,18 @@
+ squiduser=$withval)
+
+ if test -n "$sg_config"; then
+- AC_DEFINE(ACCONFIG)
++ AC_DEFINE(ACCONFIG, 1, [Defined if you supply --with-sg-config])
+ changequote(, )dnl
+ sg_cfgdir=`echo $sg_config|sed "s%/[^/][^/]*$%%"`
+ changequote([, ])dnl
+ fi
+
+ if test -n "$sg_logdir"; then
+- AC_DEFINE(ACLOGDIR)
++ AC_DEFINE(ACLOGDIR, 1, [Defined if you supply --with-sg-logdir])
+ fi
+
+ if test -n "$sg_dbhome"; then
+- AC_DEFINE(ACDBHOME)
++ AC_DEFINE(ACDBHOME, 1, [Defined if you supply --with-sg-dbhome])
+ fi
+
+ CFLAGS="$CFLAGS $db_inc"
+@@ -186,7 +186,7 @@
+ YACCLINE=""
+ fi
+ if test "$with_ldap" = "yes"; then
+- AC_DEFINE(HAVE_LIBLDAP)
++ AC_DEFINE(HAVE_LIBLDAP, 1, [Define if LDAP support should be compiled])
+ AC_RUN_IFELSE([
+
+ #include <ldap.h>
+@@ -277,7 +277,7 @@
+ CPPFLAGS="${CPPFLAGS} -I${MYSQL_INC_DIR}"
+ AC_CHECK_LIB(z, compress)
+ LIBS="-lmysqlclient ${LIBS}"
+- AC_DEFINE(HAVE_MYSQL)
++ AC_DEFINE(HAVE_MYSQL, 1, [Define if MySQL support should be compiled])
+ fi
+ fi
+ else
+@@ -380,7 +380,7 @@
+ ], dbg2_ok_version=yes, dbg2_ok_version=no, dbg2_ok_version=no)
+
+ if test $dbg2_ok_version = yes; then
+- AC_DEFINE(DB_VERSION_GT2)
++ AC_DEFINE(DB_VERSION_GT2, 1, [Define if you have dbversion greater than 3.2])
+ fi
+
+ AC_RUN_IFELSE([
+@@ -404,7 +404,7 @@
+ ], dbg3_ok_version=yes, dbg3_ok_version=no, dbg3_ok_version=no)
+
+ if test $dbg3_ok_version = yes; then
+- AC_DEFINE(DB_VERSION_GT3)
++ AC_DEFINE(DB_VERSION_GT3, 1, [Define if you have dbversion greater than 4.0])
+ fi
+
+