summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch')
-rw-r--r--net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch b/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch
new file mode 100644
index 000000000000..c294c3d79c59
--- /dev/null
+++ b/net-wireless/kismet-ubertooth/files/kismet-ubertooth-0.0_p534-respect-cflags.patch
@@ -0,0 +1,61 @@
+--- /var/tmp/portage/net-wireless/kismet-ubertooth-0.0_p534/work/ubertooth-r534/host/kismet/plugin-ubertooth-phyneutral/Makefile 2012-04-30 12:08:07.000000000 -0400
++++ host/kismet/plugin-ubertooth-phyneutral/Makefile 2012-07-23 12:50:07.883119040 -0400
+@@ -11,13 +11,12 @@
+
+ PLUGINLDFLAGS ?= $(LDFLAGS)
+ PLUGINLDFLAGS += -shared -rdynamic
+-LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+-CFLAGS ?= $(CFLAGS) $(CPPFLAGS)
++LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb -lubertooth
+ CFLAGS += -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
++CXXFLAGS += -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
+
+ SRVOBJS = packetsource_ubertooth.o packet_btbb_types.o \
+- phy_btbb.o kismet_ubertooth.o \
+- $(RXTX_SRC_DIR)/ubertooth.o
++ phy_btbb.o kismet_ubertooth.o
+ SRVOUT = ubertooth.so
+
+ all: $(SRVOUT)
+@@ -38,9 +37,9 @@
+ @-rm -f *.so
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $*.c -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
+
+ .cc.o:
+- $(CXX) $(CFLAGS) -c $*.cc -o $@
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
+
+ .SUFFIXES: .c .cc .o
+--- /var/tmp/portage/net-wireless/kismet-ubertooth-0.0_p534/work/ubertooth-r534/host/kismet/plugin-ubertooth/Makefile 2012-04-04 19:18:29.000000000 -0400
++++ host/kismet/plugin-ubertooth/Makefile 2012-07-23 12:50:07.890119040 -0400
+@@ -11,12 +11,12 @@
+
+ PLUGINLDFLAGS ?= $(LDFLAGS)
+ PLUGINLDFLAGS += -shared -rdynamic
+-LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb
+-CFLAGS ?= $(CFLAGS) $(CPPFLAGS)
++LIBS += -lstdc++ -lusb-1.0 -lpthread -lbtbb -lubertooth
+ CFLAGS += -I/usr/include -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
++CXXFLAGS += -I/usr/include -I$(KIS_INC_DIR) -I$(RXTX_INC_DIR) -g -fPIC
+
+ SRVOBJS = packetsource_ubertooth.o packet_btbb.o packet_btbb_types.o \
+- tracker_btbb.o kismet_ubertooth.o $(RXTX_SRC_DIR)/ubertooth.o
++ tracker_btbb.o kismet_ubertooth.o
+ SRVOUT = ubertooth.so
+
+ CLIOBJS = ubertooth_ui.o
+@@ -48,9 +48,9 @@
+ @-rm -f *.so
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $*.c -o $@
++ $(CC) $(CPPFLAGS) $(CFLAGS) -c $*.c -o $@
+
+ .cc.o:
+- $(CXX) $(CFLAGS) -c $*.cc -o $@
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $*.cc -o $@
+
+ .SUFFIXES: .c .cc .o